1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed jQuery Migrate

Discussion in 'Resolved Bug Reports' started by Jeremy P, Jul 12, 2013.

  1. Jeremy P

    Jeremy P Well-Known Member

    XF pages try to load jQuery Migrate (http://xenforo.com/community/js/xenforo/min/dist/jquery-migrate.min.map) but it's returning 404.

    Also once again I'd really like to recommend moving javascripts to the bottom of the page, before </body>

    Last I heard this was not done because it caused TinyMCE errors, however when moving the JS to the bottom on my own forum, nobody had any issues.. and now TinyMCE was ripped out so would it make sense to at least reconsider?
     
    Andy.N likes this.
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    I cannot reproduce this here. jQuery.Migrate is included in xenforo.js (first line).
     
  3. Jeremy P

    Jeremy P Well-Known Member

    Then the separate script needs to be removed from the HTML.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Yeah, I don't see that script being called on XenForo.com (hence my comment).
     
  5. Mike

    Mike XenForo Developer Staff Member

    This is just from the source mapping support that some browsers have now. I've just removed it.
     
  6. Jeremy P

    Jeremy P Well-Known Member

    Thanks @Mike. I know it's a separate issue but is there any good reason javascripts are placed before content?
     

Share This Page