1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 JavaScript Console Error

Discussion in 'Troubleshooting and Problems' started by TJA, Oct 31, 2014.

  1. TJA

    TJA Well-Known Member

    When un-checking any smiley in the admin panel I get this error:

    upload_2014-10-31_22-35-4.png

    Any suggestions?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Right click and enable the browser tools, then select the console tab.

    Then perform the same action.
     
  3. TJA

    TJA Well-Known Member

    Ok done that but what exactly am I looking for in all that :confused:

    Mind if I send you the error via a conversation please @Brogan
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Can you screenshot the actual error from the console window?

    There should be some entries in red text.
     
  5. TJA

    TJA Well-Known Member

    Sent in Conversation
     
  6. TJA

    TJA Well-Known Member

    Problem resolved. Was an issue with max_input_vars in the php.ini file.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I would have responded but I was watching the first episode of Dominion :D
     
  8. TJA

    TJA Well-Known Member

    Bloody charming, any good?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Not bad.

    Looking forward to see how it develops.
     
  10. TJA

    TJA Well-Known Member

    Tidy darts, might check out the pilot later, if any good I'll catch up with the series, currently on E8
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Hehehehe... the "errors" was the entire page output pretty much. I had ran into this before when I exceeded a certain amount of smilies installed - which is pretty much what happened with @thejackarmy. Once we upped the php.ini setting he denoted it started working hunky-dory. :D
     
    TJA likes this.
  12. CritiKiL

    CritiKiL Active Member

    I'm getting this same error whenever I try to 'edit a template' or make a post. And I don't understand: "Right click and enable the browser tools and then select the console tab?" - Thanks in advance

    error_message.PNG
     
  13. CritiKiL

    CritiKiL Active Member

    Oh wait (I'm using Google Chrome Brower) - Got that done now. But what do I do now that I have the console tab? This is what I'm seeing but I have no idea what to do to fix the error.

    error_message2.PNG
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Perform the same action and note the error.
     
  15. CritiKiL

    CritiKiL Active Member

    Here's the error I'm getting:

    error_message2.PNG
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    There is no error listed there.
     
  17. CritiKiL

    CritiKiL Active Member

    Wow - Now the whole page is messaged up and shows all of this in the console area. I tried to place the entire code which is all red, but it's too long...
     
  18. CritiKiL

    CritiKiL Active Member

    PHP:
    Failed to load resourcethe server responded with a status of 404 (Not Foundhttp://video.clankillas.net/wallpapers/flashheader1.jpg
    Uncaught SyntaxErrorUnexpected token forum.clankillas.net/forumrunner/detect.js:1
    Uncaught SyntaxError
    Unexpected token forum.clankillas.net/mobiquo/tapatalkdetect.js:1
    XenForo editor ctrl_message
    d.fn.d.init[1]
    Uncaught SyntaxErrorUnexpected token forum.clankillas.net/index.php?forums/sigs.73/create-thread:2174
    XenForo
    .activate(#document)
    Title Elementd.fn.d.init[1]
    flash urlhttp://forum.clankillas.net/js/swfupload/Flash/swfupload.swf
    Attachments changedtotal files0images0
    Unable to find menu 
    for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    Unable to find menu for Popup d.fn.d.init[1]
    XenForo.init() 181msjQuery 1.5.2/1.2.6-dev
    TWITTER WIDGET
    The Twitter API v1.0 is deprecated, and this widget has ceased functioning.
    TWITTER WIDGETYou can replace it with a new, upgraded widget from <https://twitter.com/settings/widgets/new/user?screen_name=clankillas>
    TWITTER WIDGET: For more information on alternative Twitter toolssee <https://dev.twitter.com/docs/twitter-for-websites>
    set prefix 0
    Failed to load resource
    the server responded with a status of 404 (Not Foundhttp://video.clankillas.net/wallpapers/flashheader1.jpg
    Failed to load resourcenet::ERR_BLOCKED_BY_CLIENT http://cdn.viglink.com/images/pixel.gif?ch=2&rn=10.498940291581675
    Invalid App IdMust be a number or numeric string representing the application id.
    FB.getLoginStatus() called before calling FB.init().
    Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inchnot dots-per-physical-inchso does not correspond to the actual 'dpi' of a screenIn media query expression: (-webkit-min-device-pixel-ratio1.5), (min-resolution144dpifollow_button.a5bbbb7216610af1306d56b0f28a67d7.en.html:1
    SWFUpload successfully initialized 
    (SWFUpload_0)
    d.fn.d.init[1control clickedNewlyOpenedfalseAnimatedfalse
    control
    d.fn.d.init[1]
    Uncaught SecurityErrorFailed to read the 'contentDocument' property from 'HTMLIFrameElement'Blocked a frame with origin "http://forum.clankillas.net" from accessing a frame with origin "https://platform.twitter.com".  The frame requesting access has a protocol of "http"the frame being accessed has a protocol of "https"Protocols must match.

    set prefix 19
    Abort pending field validation
    ...
    'Attr.nodeValue' is deprecatedPlease use 'value' instead.
    PHP <!DOCTYPE html>

    <
    html id="XenForo" lang="en-US" dir="LTR" class="Public LoggedIn Sidebar" xmlns:fb="http://www.facebook.com/2008/fbml">
    <
    head>

    <
    link href="//netdna.bootstrapcdn.com/font-awesome/3.1.1/css/font-awesome.css" rel="stylesheet">









    And this is just half of all thats there and in red...
     
  19. Brogan

    Brogan XenForo Moderator Staff Member

    The first steps would be to disable all add-ons, remove any custom JavaScript from any templates and revert to a completely default unedited style.
     
    CritiKiL likes this.
  20. CritiKiL

    CritiKiL Active Member

    Ok, I just did all of those things and the problem is still there. Doesn't allow me to make any posts or template edits, and it just started doing this.
     

Share This Page