1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.0 Issue with uploading attachments

Discussion in 'Troubleshooting and Problems' started by Sador, Jun 17, 2013.

  1. Sador

    Sador Well-Known Member


    First of all, this is very specifically not a XenForo issue, but rather an issue on the server end, either permission or restriction based. However, I'm hoping someone might know a solution.

    Whenever I try to upload an image (or other file) on my website, either through the XenForo attachment uploader or a regular HTTP / PHP uploadscript, something goes wrong. The image / file will show up in the directory, however it will be a 0 kb file and when you try to open it'll give the following error message: The image cannot be displayed because it contains errors. This has started happening since I switched hosting, it worked fine before that (both the XenForo upload and the uploadscript)


    I've looked everywhere I could find on the web, but haven't found a solution yet. As far as I can tell, it's either because:

    - Some folders don't have CHMOD 777 permissions. In an attempt to fix that, I tried applying 777 permissions to both the data and internal_data folders (and all folders / files underneath it) for XenForo. Sadly, this had no result.

    - There might be an issue with the php.ini file, for example with the upload_temp folder. I tried putting in a custom php.ini file that worked at my previous host, but sadly no result. This might be because it keeps using the host own php.ini file, but according to the host this shouldn't be the case.

    I've tried both the Flash uploader and the regular one, but both have the same issue. So, I have no clue where to go from here. I know it's somewhere server related, but I have no clue what's causing it or how to solve it. I'm hoping someone here will have some sort of idea, if not I'll start bothering my host again.

    Thanks for any help that can be given.
  2. Chris D

    Chris D XenForo Developer Staff Member

    I've seen mod_security cause issues like this in the past.

    Ask your host or server person to check if it is enabled. As purely a diagnostic measure, it should be disabled temporarily and then try again.
    Sador likes this.
  3. Sador

    Sador Well-Known Member

    It seems the problem was indeed the php.ini file; it didn't take my custom settings, and the upload_size setting was too low without it.

    Thanks however Chris for the quick reply. :)

Share This Page