XF 1.5 Is just me or do you have register/register in register_form?

dondomainer

Active member
I found this in register_form

Code:
<form action="{xen:link 'register/register'}" method="post" class="xenForm AutoValidator"
    data-fieldValidatorUrl="{xen:link register/validate-field}"
    data-normalSubmit="1"
>
I ask because i have never touched this template until now and I do not think this is correct. I'm pretty sure we all have the same because i searched in other xen sites and I get the same error.

This action is available via POST only. Please press the back button and try again.

instead of 404.

someone can confirm plz.
 

Liam W

in memoriam 1998-2020
That's not an error. That's the correct URL.

You see an error message because the URL is only supposed to be used for submitting forms - you're not supposed to point a browser to it.

Liam
 

dondomainer

Active member
That's not an error. That's the correct URL.

You see an error message because the URL is only supposed to be used for submitting forms - you're not supposed to point a browser to it.

Liam
If you make click from login page in Register, you get redirection to login/login <-- thats have to be a n error.
 

dondomainer

Active member
That's not an error. You're attempting to log in without an account so it displays the Sign up/registration page.
What is the justification for : yoursite.com/community/login/login

or in code :

Code:
form action="{xen:link 'login/login'}"

continued to

    {xen:link login/validate-field}"
 

Snog

Well-known member
There's no need for justification. But if you must know the first login is the route, the second login is the function. So it's login/login. And if you're not a member it displays the sign up page. Look at the PHP code for a better understanding of how it works.
 
Top