XF 2.2 iPhone 15 Pro Photo Uploads - "The uploaded image is too big"

Myself and a few users on my phone who have upgraded to the iPhone 15 Pro have found we can not attach photos to the forum. They just error with "the uploaded image is too big".

I have increased the max uploaded_max_filesize and post_max_size to 128M and adjusted the Maximum attachment file size in the Admin section to it's new limit of 131,072. However, the error message continues to persist.

The only thing that had any impact was setting the Maximum attachment image dimensions to 0 or blank. This then resulted in the images uploading as attachments and not as photos and no thumbnail was generated, nor could you display the image in the post. Only a link to the attachment.

I'm assuming the issue is the iPhone 15 Pro's main camera is now 24 megapixels.

So it makes me wonder if this 20 megapixel limitation from the v1.4 days, the only thing I could find by searching is what's going on here and if this would be the same way to address this issue.
I've just tried adding that to the config.php file and am still getting the same error. Does the server or apache need a restart or should just adding it to the src/config.php file be enough?

Edit: It's now working. The issue was my bad. Ubuntu keeps a copy of the www folder in the user home folder and that is where I made the edit. Not in var/www.
Last edited:
Top Bottom