• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue iOS Support?

Martyn

Active member
#1
I read that Kier used firefox chrome, Safari, iso etc to do this style,

but when i try login on my iphone 3gs i cant?... its like nothing happens even if i change style to enhancement disabled?

anyone having same problem
 

Brogan

XenForo moderator
Staff member
#2
As far as I am aware a lot of people (including Kier) browse the site on the iPhone with no problems.

Are you able to access other sites on it OK?
 

Martyn

Active member
#7
yes jailbroken and ermm cant remember what version.... >.< its on charge atm lol, ill update it tonight leave for work in an hour! and some of my apps are big!
 

cmeinck

Well-known member
#8
My readers are noting several issues with iOS on both the iPad and iPhone:
  • Selecting a profile causes a pop-up that renders at the top of the window, so the reader is unaware it's displayed without scrolling.
  • On the iPad, there is no WYSWYG editor when creating a message
I tested yesterday and this is happening on the XenForo site as well.
 

Elizabeth

Well-known member
#9
My readers are noting several issues with iOS on both the iPad and iPhone:
  • Selecting a profile causes a pop-up that renders at the top of the window, so the reader is unaware it's displayed without scrolling.
  • On the iPad, there is no WYSWYG editor when creating a message
I tested yesterday and this is happening on the XenForo site as well.
You have to be in landscape mode to see the alerts.

And you're right about no wysiwyg editor, it's just a box to type in. Not sure if they would work, not all of them.

Posting this from my 3GS
 

cmeinck

Well-known member
#10
You have to be in landscape mode to see the alerts.

And you're right about no wysiwyg editor, it's just a box to type in. Not sure if they would work, not all of them.

Posting this from my 3GS
With a forum filled with iPhone/iPad users, I cannot ask them to use landscape exclusively when using features. It's a good stop gap though for beta 1.

As for the wyswyg editor, this too seems like a necessary feature for both iPhone/iPad users.
 

Mike

XenForo developer
Staff member
#11
The popup issue is known and listed in several more reports around here.

The lack of a WYSIWYG editor is a limitation of iOS. There's nothing we can do about that.
 

cmeinck

Well-known member
#14
Thanks for the clarification. It appears someone has filed a report with Apple, so perhaps it gets fixed sometime in the future.
 
#15
The popup issue is known and listed in several more reports around here.

The lack of a WYSIWYG editor is a limitation of iOS. There's nothing we can do about that.
So why not detect if it's an iPhone, and if so, only use a standard <textarea>? That'd fix that problem right off the bat...
 

cmeinck

Well-known member
#17
So why not detect if it's an iPhone, and if so, only use a standard <textarea>? That'd fix that problem right off the bat...
That's what it does now. Of course, iPad users are expecting a full web experience, including the WYSWYG. It limits functionality for these members -- I hope Apple corrects it or we find a workaround. I have an iPhone, iPad community, so for me it's paramount that I offer a great solution to my members.
 

RobParker

Well-known member
#20
I believe that has since changed with new versions of vB. Regardless, you can use the XenForo add-on Minorin to restore an editor to iOS devices.
My point was that rather than being an iOS issue, it's an implementation issue. Rather than just blaming iOS it seems that there are options that would work.

Will check out Minorin, thanks :)