1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue ios 10 and xf isnt working well together

Discussion in 'Resolved Bug Reports' started by king8084, Jun 14, 2016.

  1. king8084

    king8084 Active Member

    As soon as you start typing, the screen focus jumps to the very bottom of the page and stays there...no way to see what you're typing right now unless you scroll up after you're done entering the text...and if you try to add/edit it then it jumps right back to the bottom

    this was done on chrome/safari on xenforo.com with the same results
  2. Chris D

    Chris D XenForo Developer Staff Member

    We will of course investigate this as soon as is reasonably possible but unfortunately you would be better at this stage reporting this to Apple.


    I recall this happening with the iOS 9 Beta, also, and it wasn't anything we could fix and Apple eventually resolved it in a newer beta.

    I suspect this will be similar.

    Unfortunately we don't have a developer account so we're unable to test it until the beta goes public next month. Also this kind of thing can be expected and one of the risks of being an early adopter of bleeding edge software releases.
    king8084 likes this.
  3. king8084

    king8084 Active Member

    will do mate

    should i say anything specific to make my wordings more understandable?
  4. Chris D

    Chris D XenForo Developer Staff Member

    I would actually try and reproduce it elsewhere.

    For example, is it happening on other sites, other software or websites?

    I seem to recall it happening in normal text area elements before which again is indicative of it being an Apple bug.

    If you can reproduce it on other sites, such that don't require registering or using a specific software it will be easier for them to reproduce it.

    Let us know how you get on.
    king8084 likes this.
  5. king8084

    king8084 Active Member

    facebook works fine
    engadget works fine
    complex does the same as here...think they're wordpress
  6. vbresults

    vbresults Well-Known Member

    This occasionally happens in OSX Safari, specifically here in the RM when editing a resource, but I can't recall exactly what triggered it. I know it has something to do with the editor. Next time I trigger it, will post an update here with whatever details I gather.
  7. vbresults

    vbresults Well-Known Member

    This happens when you try to select text with the mouse in the RM. When you do this, it jumps to the bottom of the page. Seems to not affect the popup editor or quick reply box.
  8. Chris D

    Chris D XenForo Developer Staff Member

    This sounds like a separate issue.

    Unless this report relates specifically to iOS 10, then it will need to be reported in a separate thread. If it's exclusive to the RM then that would need to be reported in the Resource Manager Bugs forum.

    Please include device make/model and iOS version when reporting.
  9. king8084

    king8084 Active Member

    beta 2 is out today, and this has been semi fixed, typing doesnt break the page anymore but hitting backspace does

    we getting there
    Chris D likes this.
  10. Chris D

    Chris D XenForo Developer Staff Member

    Dev beta 4 and public beta 3 have solved this issue.
  11. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    I can definitely confirm that. Noticed today things were working right.

Share This Page