• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Invalid URI supplied error

D.O.A.

Well-known member
#1
hi, i recently got elasticsearch running on centos via the guide here. At first I couldnt get anything to reindex, so I followed the thread here.
http://xenforo.com/community/threads/elasticsearch-running-but-xf-wont-reindex.26173/#post-315213
Code:
# set, it is automatically derived. It must point to an actual IP address.
# network.publish_host: 127.0.0.1
# Set both 'bind_host' and 'publish_host':
  network.host: 127.0.0.1
Stopping ElasticSearch...
Stopped ElasticSearch.
Starting ElasticSearch...
Waiting for ElasticSearch......
running: PID:xxxxx
I assumed these settings were to be uncommented and given the localhost IP in the xenforo options, so I did that. However when I returned to the tools > elasticsearch options I recieve this error:
Code:
[*]Server Error
Invalid URI supplied
Zend_Uri_Http->__construct() in Zend/Uri.php at line 143
Zend_Uri::factory() in Zend/Http/Client.php at line 270
Zend_Http_Client->setUri() in Zend/Http/Client.php at line 253
Zend_Http_Client->__construct() in XenForo/Helper/Http.php at line 34
XenForo_Helper_Http::getClient() in XenES/Api.php at line 35
XenES_Api->__construct() in XenES/Api.php at line 53
XenES_Api::getInstance() in XenES/ControllerAdmin/Elasticsearch.php at line 7
XenES_ControllerAdmin_Elasticsearch->actionIndex() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /xxxx/xxxx/public_html/forum/admin.php at line 13
tried re-uploading the files, to no avail. Any suggestions how I broke it?
 

D.O.A.

Well-known member
#2
it's fixed, must have been an uploading error as the .php file sizes changed when I updated my ftp software, it was probably uploading them incorrectly to begin with. using network.host: 127.0.0.1 works :)