1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Intallation error

Discussion in 'Installation, Upgrade, and Import Support' started by epiom, Jul 2, 2011.

  1. epiom

    epiom Member

    I created a ticket yesterday but no answer yet so ill write my problem here.

    First of all the installation was long, very long at the step : Rebuilding... Phrases (Importing)

    After that i get a button to rebuild the cache, cliced on it and waited. Then i get this error :

    Server Error

    Mysqli statement execute error : Duplicate entry '0-permission_profilePost_viewModerated' for key 2

    Zend_Db_Statement_Mysqli->_execute() in /home/fragsqc/public_html/forums/library/Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in /home/fragsqc/public_html/forums/library/Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in /home/fragsqc/public_html/forums/library/Zend/Db/Adapter/Abstract.php at line 574
    Zend_Db_Adapter_Abstract->insert() in /home/fragsqc/public_html/forums/library/XenForo/Model/Phrase.php at line 902
    XenForo_Model_Phrase->insertPhraseMapForLanguages() in /home/fragsqc/public_html/forums/library/XenForo/CacheRebuilder/Phrase.php at line 37
    XenForo_CacheRebuilder_Phrase->rebuild() in /home/fragsqc/public_html/forums/library/XenForo/ControllerHelper/CacheRebuild.php at line 26
    XenForo_ControllerHelper_CacheRebuild->rebuildCache() in /home/fragsqc/public_html/forums/library/XenForo/Install/Controller/Install.php at line 239
    XenForo_Install_Controller_Install->actionStep2b() in /home/fragsqc/public_html/forums/library/XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in /home/fragsqc/public_html/forums/library/XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/fragsqc/public_html/forums/install/index.php at line 17

    I'm running on a VPS Fully managed, PHP Version 5.2.17 - MySQL 5

    Someone had this error before?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is this a clean install?
    It shouldn't take more than 30 seconds or so for the phrases.

    As a first step you could try wiping the server and database, uploading all of the files again and running the installation process once more.
    That will rule out any issues related to the server files due to the FTP process.

    When did you raise the ticket?
    Unfortunately it's now the weekend so there won't be any response to that until Monday morning at the earliest.
  3. epiom

    epiom Member

    I tried a clean install 3 times, the last time i was at the Rebuilding... Phrases step and the page was loading for 10 minutes.. never ended loading. :(
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Did you try uploading the files again just in case?
    I don't think it will make a difference but it's worth a try.

    Download a fresh zip package from your customer area and then FTP it to your server.
  5. epiom

    epiom Member

    Yep uploaded the files on the FTP 3 times, always with a clean DBB and tested with a new download of the package.
  6. tonjohn

    tonjohn Member

  7. epiom

    epiom Member

    I opened a support ticket and Mike have modified some files i think and it worked...but each adddon install can take 30 min so i moved to another vps company (site5) who have different datacenter location and now it work like a charm.

  8. tonjohn

    tonjohn Member

    I fixed this by adding
    to the config.

    The install took over 15 minutes to run. What would cause it to take so long?

Share This Page