1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 "Insufficient privilages"

Discussion in 'Troubleshooting and Problems' started by Bulbagarden, Nov 12, 2015.

  1. Bulbagarden

    Bulbagarden Member

    Well, I'm stumped. And I get the feeling that whatever the solution is, it's going to make me feel very silly.

    For some reason, I'm finding myself unable to post new threads anywhere on my (newly transferred from vBulletin) forum. And I'm having a heck of a time tracking down whatever could be causing it.

    My staff members aren't experiencing any problem posting. I've already tried to match my usergroups to theirs to see if that would fix the problem, with no success. When we have identical usergroups, they can post threads but I still can't. That rules out something stupid like not having "Allow new messages to be posted in this forum" ticked (it's ticked everywhere I've tried to post), or something being set to "private node".

    I've used the permissions analyzer to check my global thread creation permissions, as well as my thread creation permissions in the individual forum nodes, and there's no problems there.
    I've checked my own individual user permissions, my admin and moderator permissions. Nothing there that looks out of the ordinary. The only difference between myself and one of my admins who can access everything is that I have hard delete powers and they don't.

    So... what could be causing this? What have I missed?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you run the permissions analyzer in the nodes too?

    If you are only in the Registered and Administrative user groups and there is no Never set anywhere, then it could be some sort of permission corruption due to the import.

    Toggling a permission on and off and saving may update the cache.
     
  3. Bulbagarden

    Bulbagarden Member

    Yes, I've run the permissions analyzer in the nodes. All of them show a Final Value (Content) of Yes for "Post new thread". Some of those are with a revoke in registered for content permissions and an allow for admin, others just show the allow for registered.

    My first thought was a permissions corruption of some sort also, however wouldn't that prevent *anyone* who was part of those usergroups from posting? Why would people with identical usergroup combinations be successfully posting when I can't? The only thing I don't share with anyone else is that my account is the only current super admin. But even there, I'd tried changing config.php so I wasn't a super admin, refreshing the forum, returning config.php to normal, and refreshing again. As expected, it made no difference.
     
    Last edited: Nov 12, 2015
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you submit a ticket with ACP (2FA disabled) and phpMyAdmin access, as well as links to the nodes you are having issues with, I can take a look.
     
  5. Bulbagarden

    Bulbagarden Member

    The problem seems to have resolved itself overnight while I slept. I'm guessing it was some kind of stuck permission that sorted itself out? Whatever it was, just glad it's over. Thanks for your suggestions Brogan and your offer to troubleshoot.
     

Share This Page