1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing xenForo (Testing so I can learn)

Discussion in 'Server Configuration and Hosting' started by Yashjeet, Jan 9, 2014.

  1. Yashjeet

    Yashjeet Active Member

    Hello,

    I'm currently learning Linux on installing xenForo however, i'm on centOS and when I ran this command -
    cp /usr/local/lsws/phpbuild/php-5.4.17/php.ini-development /usr/local/lsws/lsphp5/lib/php.ini It gave me the following output -
    [root@vps ~]# cp /usr/local/lsws/phpbuild/php-5.4.17/php.ini-development /usr/local/lsws/lsphp5/lib/php.ini
    cp: cannot stat `/usr/local/lsws/phpbuild/php-5.4.17/php.ini-development': No such file or directory
    I've done everything through out these guides -

    PART 1 - http://xenforo.com/community/resour...tos-openlitespeed-percona-with-pictures.1844/

    PART 2 - http://xenforo.com/community/resour...tos-openlitespeed-percona-with-pictures.2258/'

    (I'm on the Part 2, everything went fine up until the command specified above)'

    Is their any help? I'm on the PHP build 5.4.22. Also, I followed the guide step by step!
     
  2. Yashjeet

    Yashjeet Active Member

    Oh yeah, this is @Slavik 's guide! (I think)
     
  3. Slavik

    Slavik XenForo Moderator Staff Member

    Look in the paths your moving. You need to change php-5.4.17 to 5.4.22
     
  4. Yashjeet

    Yashjeet Active Member

    Wow, I'm such a derp. I'll fix it, thanks man :)
     
  5. Yashjeet

    Yashjeet Active Member

    Hi,
    I did that, it worked nicely. However, When I went to the step to Edit port 8080 to 80, I went to http://162.221.176.76/ and a Apache page came up.
     
  6. Slavik

    Slavik XenForo Moderator Staff Member

    yum remove httpd

    Then do a graceful restart of litespeed.
     
  7. Yashjeet

    Yashjeet Active Member

    Okay, I've tried that and now it doesn't load anything! http://162.221.176.76/
     
  8. Slavik

    Slavik XenForo Moderator Staff Member

    Double check your litespeed settings, try moving it back to 8080 and if that works, then try moving to 80 again. The fact you had apache installed and running also suggests you wernt using a minimal centos install, so it may have installed other stuff for you aswell...
     
  9. Yashjeet

    Yashjeet Active Member

    YOURSERVERIP:80 doesn't work. This works though YOURSERVERIP:8088. Now... I have another problem, when I navigate to find /etc/my.conf/ it can't find it, it doesn't exist. What do I do to fix this?
     
    Last edited: Jan 9, 2014
  10. Slavik

    Slavik XenForo Moderator Staff Member

    That wont exist :)

    Its /etc/my.cnf

    If 8088 is working, then you havent re-bound it correctly. Double check your settings.
     
  11. Yashjeet

    Yashjeet Active Member

    I tried /etc/my.cnf it still didn't work.
    Also, The settings are fine, I think. Here's the out put!
    Listener Name[​IMG]Default
    IP Address[​IMG]


    ANY
    Port[​IMG]80
    Binding[​IMG]Not Set
    Secure[​IMG]No
    NotesNot Set
    Should I re-try the whole process from step 1..?
     
  12. Slavik

    Slavik XenForo Moderator Staff Member

    Yea, I would nuke and reload your server. Try to ensure its a *minimal* install if your host gives the option.

    If not, the first thing you should do is stop apache and remove it before going through my guide.
     
  13. Yashjeet

    Yashjeet Active Member

    Okay, will re-boot it now! :D, Please check back the thread if I need help, lol.
     
  14. Yashjeet

    Yashjeet Active Member

    Hi,
    I re-installed everything (Didn't install anything, re-installed the OS and did part 1, into part 2.) However, when I went to http://162.221.176.76/ it does the apache and I didn't even install apache.
     
  15. Slavik

    Slavik XenForo Moderator Staff Member

    Yea, your hosts install probably loads a bunch of stuff on there you don't want.

    Stop and remove it first and then try again.
     
  16. Yashjeet

    Yashjeet Active Member

    I'm using a VPS. I have a dedicated server that i'm running my minecraft server on. Should I go on their? Or, how do I remove apache?
     
  17. Slavik

    Slavik XenForo Moderator Staff Member

    Never mess around on a live server unless your compfortable with reverting any changes.

    Assuming its installed via yum

    yum list installed http

    and then use yum remove on any installed packages.
     
  18. Yashjeet

    Yashjeet Active Member

    Okay, I did yum remove httpd. Now.., I did EVERYTHING right and I know it. I made it port 80, and once when I removed apache http://162.221.176.76/ doesn't work anymore. It just says reload page. What should I do now.
     
  19. Slavik

    Slavik XenForo Moderator Staff Member

    Go debugging :D
     
  20. Yashjeet

    Yashjeet Active Member

    What do you mean? You want me to continue the process?
     

Share This Page