• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Installation Welcome Screen Loop

#1
I have recently purchased a license and uploaded all the files. When I run the installer an go to the next step, it does not advance past the Welcome page. Does anyone have any idea how to fix this? I already chmodded all the files and rewrite is enabled.

I'm using a VPS running Ubuntu 12.04 LTS. Server is Apache 2.2 and PHP version installed is 5.4 (using php-fpm).
 
Last edited:

Jake Bunce

XenForo moderator
Staff member
#2
Any specific errors? What exactly happens when you click for the next step? Ideally there will be some error or output.
 
#3
I installed it on a different server and then move the files back and importing the database, and now it appears to work, but none of the pages works as it gives a 404 error as seen in my access log.

- - [21/Jul/2015:05:34:34 +0000] "GET /index.php HTTP/1.1" 404 5513 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/600.7.12 (KHTML, like Gecko) Version/7.1.7 Safari/537.85.16"

This indicates a problem with the apache configuration, but I do have AllowOverride enabled, which makes me even more puzzled as I don't have any problems with Wordpress using rewrite with the same server configuration.

Here is my VHost configuration:
Code:
DocumentRoot /home/chikorita157/abcafe
<Directory /home/chikorita157/abcafe>
        Options Indexes FollowSymLinks MultiViews
                AllowOverride All
        Order allow,deny
        allow from all
</Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride All
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /var/log/apache2/aberror.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/abaccess.log combined
ServerName abcafe.ateliershiori.moe
Also, the figuration to make PHP5-FPM work with fastcgi
Code:
<IfModule mod_fastcgi.c>
    AddHandler php5-fcgi .php
                Action php5-fcgi /php5-fcgi
                Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi
                FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -host 127.0.0.1:9000 -pass-header Authorization
</IfModule>
Update: I reverted back to mod_php and everything works.
 
Last edited: