1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installation - Tranfer Node Tree to New Domain

Discussion in 'Installation, Upgrade, and Import Support' started by GothamHoops, Oct 18, 2011.

  1. GothamHoops

    GothamHoops Member

  2. kkm323

    kkm323 Well-Known Member

    you would need to transfer your database to the new site. If you are you using the same host , juts rewrite your config file in the library directory.
     
  3. GothamHoops

    GothamHoops Member

    how exactly would i do that? i'm sorry
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Both of your domains appear to be hosted on the same server so you don't need to do a full server move. Just copy the forum files to the new domain and leave the library/config.php file pointing to the same database. Then update the board URL in the Admin CP:

    Admin CP -> Home -> Options -> Basic Board Information -> Board URL

    If the two sites were on separate servers then you would need to do a full move which is a backup + restore from the old server to the new one:

    http://xenforo.com/community/threads/how-to-backup-and-restore-your-forum.7213/
     
  5. GothamHoops

    GothamHoops Member

    Copy every file or specific ones? Thanks!
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    All of them. For example, if your forum is installed at yoursite.com/forum/ then you would copy the entire forum/ directory.
     
  7. GothamHoops

    GothamHoops Member

    I've been trying to work this out but my posts aren't transferring still
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The posts are stored in the database and should be preserved as long as the library/config.php file points to the same database as before.
     
  9. kkm323

    kkm323 Well-Known Member

    try to remember your old database information and add it in config.php
     
  10. GothamHoops

    GothamHoops Member

    I found the config.php file but nothing altered when I dragged it to the new directory
     

Share This Page