1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installation error when rebuilding search index

Discussion in 'Enhanced Search Support' started by X3nman, Apr 20, 2013.

  1. X3nman

    X3nman Member

    Elasticsearch indexing failed for post- Elasticsearch error: InvalidIndexNameException[[Admin] Invalid index name [Admin], must be lowercase] - library/XenES/Search/SourceHandler/ElasticSearch.php:713

    That is the report from server error log.

    My database name start with an uppercase letter, is that the issue?

    If yes, in phpmyadmin do I just choose rename the databse from operations, then edit the config.php to reflect the new database name?

    Also the database username starts with an uppercase letter, does that matter?

    Or am I way off?

    thanks for any help.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Not an error I've heard of before.

    You can try renaming the database and updating config.php to see if that resolves it.
     
  3. X3nman

    X3nman Member

    ok thanks Brogan, I'll post back and let everyone know.
     
  4. X3nman

    X3nman Member

    I renamed the database in phpmyadmin and i config.php.
    when I tried to browse the forum again I got the error...

    'The database has encountered an unexpected error'

    I renamed the databse and config.php back to original and all is working again.
    But what am I missing? Why did it give me that error?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Could have been a cache or Apache issue.

    Viewing page source may have given more details.
     
  6. X3nman

    X3nman Member

    im on nginx.
    thanks for the tip, i'll have another go
     
  7. X3nman

    X3nman Member

    OK all is good now, everything is working.
    So to let others know what the problem was and how to resolve it.....

    The original error I got after installing the enhanced search and trying to rebuild the search index.
    Elasticsearch indexing failed for post- Elasticsearch error: InvalidIndexNameException[[Admin] Invalid index name [Admin], must be lowercase] - library/XenES/Search/SourceHandler/ElasticSearch.php:713

    This refers to the index name/database name (mine is called Admin) and telling me that it needs to be lowercase.
    I renamed the database to admin through phpmyadmin.
    To do this I went into the database, selected the operations tab and entered 'admin' into the 'change database name' box, then hit go.

    It will ask you if you want to drop the original database after copying, this is ok.



    After all this you need to add the new table name to the users permissions.

    Done.
     
    AndyB likes this.
  8. Mike

    Mike XenForo Developer Staff Member

    It's too late now, but you can tell XF to use a different elasticsearch index name, it just defaults to the database name (will probably need to strtolower it - I didn't realize there was a case issue). You can configure this under "search options" (same place where ES was enabled).
     
    Moshe1010 and Brogan like this.

Share This Page