1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Install Addons via Command Line?

Discussion in 'Troubleshooting and Problems' started by taylor_smith, Mar 29, 2014.

  1. taylor_smith

    taylor_smith Well-Known Member

    My server keeps timing out when I try to install new addons. Is there a way to install the addon .xml files via command line? My Linux fu isn't strong.


    Specs aren't the problem, don't think:

    Dual Intel L5420 2.5 Ghz (Quad Core) - veritas (04/10/2014 - 05/09/2014)
    Port Speed: 100 Mbps (10 TB Bandwidth)
    Operating System: Centos 6
    Hard Drive #1: 500GB Sata Western Digital Black
    Hard Drive #2: 500GB Sata Western Digital Black
    Hard Drive #3: 500GB Sata Western Digital Black
    Hard Drive #4: 500GB Sata Western Digital Black
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Can you describe what the timeout is? Is it max execution time? What is the error it gives you?
     
  3. taylor_smith

    taylor_smith Well-Known Member

    500 internal server error
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    And what do your web server logs report the error as?
     
  5. taylor_smith

    taylor_smith Well-Known Member

    Well, I'm installing a plugin. First time I hit the internal server error, I didn't see anything in the server error log. Second time, error about finding a duplicate column.
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    Internal server errors are thrown by the web server. So you would need to check your apache or similar logs.
     
  7. taylor_smith

    taylor_smith Well-Known Member

    Aside from missing "badges," the only errors I see in the cPanel error log are:

    [Sat Mar 29 08:43:07 2014] [error] File does not exist: .../public_html/community/data/attachments/16/16853-223032706a5dc70850fb26e3cf95713d.jpg
    [Sat Mar 29 08:25:25 2014] [error] File does not exist: .../public_html/community/styles/default/xenforo/avatars/avatar_male_s.png, referer: http://stratics.com/community/forums/uo-rares-collector.43/
    [Sat Mar 29 05:38:23 2014] [error] File does not exist: .../public_html/community/data/sitemaps
     
  8. taylor_smith

    taylor_smith Well-Known Member

    Just tried increasing memory limit. Re-installed and...

    [​IMG]
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    Are there any errors logged in MySQL logs?
     
  10. taylor_smith

    taylor_smith Well-Known Member

    Just the duplicate table error.
     
  11. taylor_smith

    taylor_smith Well-Known Member

    Same error when trying to delete. Here's with the chrome console open:

    [​IMG]
     
  12. taylor_smith

    taylor_smith Well-Known Member

    Yep, same error deleting.

    [​IMG]
     
  13. taylor_smith

    taylor_smith Well-Known Member

    All these timeouts happened in Chrome. First try in IE 11, it worked. No timeout.
     
  14. Tracy Perry

    Tracy Perry Well-Known Member

    When you say you increased the memory limit did you also restart apache and (if using it) php5-fpm?
     
  15. taylor_smith

    taylor_smith Well-Known Member

    Our DBA did it. I assume so
     
  16. taylor_smith

    taylor_smith Well-Known Member

    Scratch that. It worked in IE for our DBA, but it's not working for me. Not it Chrome, not in IE, not in FireFox. Same error. This includes both uploading the XML AND installing from the server.

    My Internet speed right now (per speedtest.net) is 58 Mbps down, 39 Mbps up. I'm totally clueless.

    Rebooted the server and tried again in IE. Looking at server processes. Currently, about 10% CPU usage and 7% memory usage on the whole server. Why it's timing out, I have no idea. I can't upload an addon. There's no error logs--not in the ACP, not in the server error logs, nowhere. This makes no sense and is incredibly frustrating.

    Every time I re-try the install, users stop being able to post/create threads, even after timeout. Have to reboot all over again. I'm lost.
     
    Last edited: Mar 30, 2014

Share This Page