1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Infinite loop when enable Flexible SSL Cloudflare

Discussion in 'Server Configuration and Hosting' started by Nobita.Kun, Dec 27, 2014.

  1. Nobita.Kun

    Nobita.Kun Well-Known Member

    Hi all. Can you tell me any config to prevent infinite loop when I enable Flexible SSL Cloudflare. On my site also using extra SSL from another service. Anytime when I active Cloudflare. My site get Infinite loop :cry::cry:
     
    Last edited: Dec 27, 2014
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Are you on the free plan or the paid one?
    Did you already have SSL configured prior to this?
    You say you enable Flexile SSL? Is that a form of SSL from CloudFlare? Or are you referring to the style Flexile?
     
  3. Nobita.Kun

    Nobita.Kun Well-Known Member

    Hi @Tracy Perry

    Q1: Im on Free plan
    Q2: Yep! I have purchased another service for SSL.
    Q3: Hi. Sorry. That is Flexible SSL on Cloudflare.
     
  4. Solidus

    Solidus Well-Known Member

    Why not use full SSL from cloudflare with a self signed certificate?
     
  5. Nobita.Kun

    Nobita.Kun Well-Known Member

    Because I have got one!
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    I think you still have to get a certificate from THEM to use also.
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Doing some further checking... if you already have a valid SSL, then you should be in reality using the Full SSL option (if you are already running your HTTP server with SSL).
    If you are wanting to use your current certificate with CloudFlare, I don' t believe the free plan offers that ability where you use it directly. You have to use the Universal one, and that takes about 24 hours to receive after you apply for it.
     
    Nobita.Kun likes this.
  8. Nobita.Kun

    Nobita.Kun Well-Known Member

    Yep! I have read before. But did not have any lucks
     
  9. Nobita.Kun

    Nobita.Kun Well-Known Member

    NVM! Im just change to FULL option. Seem my site work. :)
     
    Tracy Perry likes this.
  10. Mr. Goodie2Shoes

    Mr. Goodie2Shoes Well-Known Member

    So, are you using any kind of redirection on your server end to redirect users from http to https? If so, that's the reason as enabling Flexible means CF will contact your server via http even if visitors browse your site via CF's https.
     

Share This Page