1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 index.php Error

Discussion in 'Troubleshooting and Problems' started by Connor Smith, Jul 18, 2014.

  1. Connor Smith

    Connor Smith Active Member

    So before I start I wasn't sure where to put this.
    So when I load up my forum, and only use the route directory (www.example.com/community) I get this:

    But when I add the "index.php" to the url, it comes out fine:


    Was wondering how to fix this to work both ways.
  2. Connor Smith

    Connor Smith Active Member

    Posted this in the wrong section, could a Staff member move it please? :) thanks
  3. Mike

    Mike XenForo Developer Staff Member

    I can't see the issue you're reporting on your site.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can reproduce it.

    When I visit http://vanticraft.org/secretsociety/ the base href is:

    <base href="http://vanticraft.org/" />
    That is incorrect and is the cause of your problem.

    Here are some things to try:

    1) Revert this template in your custom style:

    Admin CP -> Appearance -> Templates -> PAGE_CONTAINER

    2) Disable your addons in the Admin CP.

    3) This could also be the result of multiple .htaccess files in play. In your /secretsociety directory, edit the .htaccess file and change this line:

    #RewriteBase /xenforo
    ...to this:

    RewriteBase /secretsociety
    Also, please post the contents of the .htaccess file in your web root.
    Connor Smith likes this.

Share This Page