Browser issue Inconsistent forum home page scroll behavior, after user taps on forum logo from forum home page (Chrome mobile)

Affected version
2.2.4

Avensen

Member
How to reproduce:
  1. create a new XenForo v2.2.4 demo at https://xenforo.com/demo/
  2. navigate to the demo forum home page with Chrome mobile;
  3. scroll to the middle or to the bottom of the page;
  4. tap on the forum logo at the top sticky navigation area;
  5. after page reloads, see if page view is at the top or at the position before reload (middle/bottom);
  6. repeat steps 3-5 several times.
Expected behavior: page does not scroll down after reload, always stays at the top.
Actual behavior: sometimes page scrolls down to the last position before reload, sometimes stays at the top.

No such issue on Chrome desktop or Safari mobile.
Could not reproduce this issue at https://xenforo.com/community/ on Chrome mobile.

Tested with Chrome mobile (87.0.4280.163) on an iPhone.
 

Mike

XenForo developer
Staff member
To be honest, I'm pretty sure this is mostly just down to an internal browser decision and not something we're trying to influence. You can see some situations like this such as submitting an options form in the control panel; the page may reload at the same position.

This is likely down to a browser heuristic based on the fact that you're reloading the page with the same URL. If you reloaded the page, it's reasonable to maintain your current scroll position if possible. A link that loads the same URL as the current page may be treated as a reload.

Inconsistency in behavior may be down to how the page gets painted and when the browser triggers things. Ultimately, not something we really have any control over.
 
Top