1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed In the ACP nothing gets checked if it has content.

Discussion in 'Resolved Bug Reports' started by Vincent, Feb 5, 2011.

  1. Vincent

    Vincent Well-Known Member

    The following blocks are affected:
    • Installed Add-ons
    • Recent Spam Cleaning
    If these blocks have no content (I'll take "Recent Spam Cleaning" as example), they just show up as an empty table.

    I'd suggest a check if they have content and if not, they don't show.
     

    Attached Files:

    • rsc.png
      rsc.png
      File size:
      5.9 KB
      Views:
      5
  2. Alluidh

    Alluidh Well-Known Member

    I don't think so.

    And this isn't a bug ;)
     
  3. Vincent

    Vincent Well-Known Member

    I just don't see any reason for having an empty table :)
     
  4. Shamil

    Shamil Well-Known Member

    I'd say this is a small improvement, and not a bug.
     
  5. dutchbb

    dutchbb Well-Known Member

    It's more a suggestion than a bug, but the idea to hide things when they have no content is a good one I think. For example why not hide the moderator bar at the top of pages when there's nothing to moderate? It removes code and clutter when it is not needed.
     
  6. Alluidh

    Alluidh Well-Known Member

    But it need the question "do we need to show?"

    Some times it is a good idea to hide things, but sometimes is is not needed. For example the "Installed Add-ons"-Part. Included in that block there are management-links and it is a good idea to have the links included. And after using and installing one add-on the question "do we need to show? keeps alive and the answer is "yes" all the time :)

    And yes, as I repeat, it's not a bug, it's a suggestions :D
     
  7. Vincent

    Vincent Well-Known Member

    That's something different in my eyes. The moderation bar needs to be there at all time, since the ACP link is there.
    That's something that shouldn't be deleted.

    Also, if you're a moderator and no ACP link is there, you still need that link to go to "Closed Reports" for if you'd like to check something.

    When empty, the only link there are "Install Add-on" and "Manage Add-ons".
    Now, those 2 links can also be found in the navbar. At the bottom.
    They link to the same.
     
  8. Alluidh

    Alluidh Well-Known Member

    I notice that but I (maybe only I) like the links on that place

    There are a lot of double links in XenForo and most of them help to make things easier and better to work with ;)
     
  9. dutchbb

    dutchbb Well-Known Member

    Yes, but the bar could be reduced to a 'Show bar' link on the right (like the 'Login or Sign up' link), when there's no new report. The bar is rather distracting/tedious to be showed all the time imo.
     
  10. Vincent

    Vincent Well-Known Member

    Yeah, indeed, well, actually I'm not talking about the Installed Add-ons block (most persons have 1 add-on or more installed), but more about the "Recent Spam Activity". It's just standing there with no use for me. I've never had spam in my whole life.

    Well, yeah, I agree with that :)
     
  11. Alluidh

    Alluidh Well-Known Member

    You must be a very lucky guy or you never used a vB :D

    <I had to go back to topic :D>
     
  12. Vincent

    Vincent Well-Known Member

    Oh, well, I never had at the site that I own(ed) :)
    At vB4Style.com spam is on :p
     
  13. Kier

    Kier XenForo Developer Staff Member

    Fixed.
     

Share This Page