1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Importing XF to XF, everything is fine, but no post content.

Discussion in 'Installation, Upgrade, and Import Support' started by drastic, Jun 5, 2015.

  1. drastic

    drastic Well-Known Member

    Merging two sites.

    Importing XF to XF.

    Everything went through fine except the content of the posts. The nodes and titles went through ok, but when you open the post, there's no content anymore.

    Any suggestions?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What are the versions of both the target and destination forum?

    Are there any add-ons installed in either one?

    Does the content show with all add-ons disabled in a completely default unedited style?

    Can you post links to some working and non-working posts?
     
  3. drastic

    drastic Well-Known Member

    I upgraded both to latest XF, ran import again, getting no post content.

    I entered the exact paths to data/internal_data for the site getting imported - it said my path to data couldn't be found. Tried again, said same thing. Leaving those fields blank was the only way the importer would run.

    The nodes/threads are there, but the threads have no content.

    See the category labeled "webmasters" - those posts are the weird ones. The rest of the site and its original content work fine.

    http://www.techmantis.net/forums/

    not working
    http://www.techmantis.net/forums/threads/html5-web-designs-popular-or-not.3128/

    working -this wasn't imported, but it works.
    http://www.techmantis.net/forums/threads/open-source-video-editors.2626/#post-21745
     
  4. Mike

    Mike XenForo Developer Staff Member

    Can you run this query?

    Code:
    SELECT * FROM xf_post WHERE thread_id = 3128;
     
  5. drastic

    drastic Well-Known Member

    @Mike - where do I run that?

    I noticed all the imported articles have the number 0 at the end.
     
    Last edited: Jun 8, 2015
  6. batpool52!

    batpool52! Well-Known Member

    phpMyAdmin
    upload_2015-6-8_15-3-23.png
    If you don't have phpMyAdmin, you'll need to run the query in mysql command line style.
     
  7. New Joe

    New Joe Active Member

    Did you rebuild all Thread and Post info in the Admin panel after the Import?
     
  8. drastic

    drastic Well-Known Member

    rebuilt everything, no change.

    here's what the query provided.

    db sql.jpg
     
  9. Mike

    Mike XenForo Developer Staff Member

    Do you have any add-ons installed on the target forum? It's possible one of these is interfering. Looking at the code, if there are no posts available for the thread, it won't be imported. That would point to something else blocking the actual import of the data.

    You may need to revert to a pre-import backup and try again, ensuring no add-ons are enabled on the target site.
     
  10. drastic

    drastic Well-Known Member

    I'll disable all addons and run the import again.
     
  11. drastic

    drastic Well-Known Member

    @Mike disabling all addons let the import go through perfectly.

    Thanks for suggesting that.
     
    The Forum Heroes likes this.

Share This Page