XF 1.4 Importing to temporary folder and later to premanent one

#1
Hello,

I have VB 4.2 installed in mydomain.com/forum
I created a TEST folder (mydomain.com/test) and installed XF there and I am going to upload the database from my VB there.

How can I later move the TEST folder/installation to the FORUM folder.
I think I have to get rid of the VB installation first.
If I rename the TEST folder to FORUM(of course, I have to change the current FORUM folder with Vbulletin to a different name).
I read that I have to later change URL in XF pane and also some things about redirection which I do not fully understand.
Do I have to create somewhere .htaccess?, write something in it? if yes what? etc.


Is it a good way to preform converting from VB to XF I am doing now or is it other better way?

I also read something about restarting server. I am on a shared hosting so I do not think this is possible there. So what I have to do if I must do that?
 
Last edited:
#3
Just this?
Don`t I have to think about .htaccess, restarting server etc.?
By move the file you mean paste them into mydomain.com/forum and get rid of vbulletin files from that location?
 
Last edited:

Brogan

XenForo moderator
Staff member
#4
You won't need redirects as you're just doing an import in a temporary location.

Literally you need to do the following:

1. Archive (or delete) the vB installation from domain.com/forum
2. Move the XenForo installation to where the vB installation was (domain.com/forum)
3. Update the Board URL in the ACP

In rare cases, a server restart may be required but generally not.
 
#5
A few problems.

New Profile Posts (on my forum home page) for some reason show older posts e.g. from April while I have posts from this month).

After the transfer from vbulletin all works but I noticed that some pages are not showing on Xenforo e.g.: Privacy statement, Terms of Use,
Also, I had a small blog page on VB and I do not see it now.
Can I find those pages somewhere and set up?
 
Last edited:

Mike

XenForo developer
Staff member
#8
New Profile Posts (on my forum home page) for some reason show older posts e.g. from April while I have posts from this month).
Can you point us to one of those profile posts? I have looked around a bit but haven't seen any. (I also don't see the new profile posts on the forum list.)

After the transfer from vbulletin all works but I noticed that some pages are not showing on Xenforo e.g.: Privacy statement, Terms of Use,
Also, I had a small blog page on VB and I do not see it now.
Can I find those pages somewhere and set up?
I'm not sure what these pages are that you're referring to (as in, how they were created), but I don't think any pages would be imported. (You also mention "blog page" but I'm not sure if you're referring to blogs, but they wouldn't be imported either.)
 
Top