1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Importing from MyBB

Discussion in 'Installation, Upgrade, and Import Support' started by Jens1986, Jan 23, 2014.

  1. Jens1986

    Jens1986 Active Member

    Hi,

    I just bought the license, and I am really looking forward to moving from MyBB to XF! I am uploading the XF files to my server as I write this.

    Couple of questions;
    There is an integrated MyBB->XF converter?
    Do I follow these steps http://xenforo.com/help/installation/ when I want to convert from MyBB, or do I have to do something else?

    Thanks!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Jens1986 likes this.
  3. Jens1986

    Jens1986 Active Member

    Thanks.

    Ran into a problem when I try to import:

    Error
    The attachments directory could not be found.

    I have installed Mybb at mydomain.com, and XF at mydomain.com/forum. I have double checked that "uploads" is the correct attachments path (url mydomain.com/uploads). Any suggestions?
     
    Last edited: Jan 23, 2014
  4. Brogan

    Brogan XenForo Moderator Staff Member

    What did you enter for the path?
    You may need to use an absolute URL.
     
  5. Jens1986

    Jens1986 Active Member

  6. Jens1986

    Jens1986 Active Member

    fixed: contacted my host
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Sorry, I was busy writing some code.

    What was the solution in the end for anyone else who might encounter the same problem?
     
  8. Jens1986

    Jens1986 Active Member

    I had written the "absolute path" or whatever its called wrong :)
     
  9. Jens1986

    Jens1986 Active Member

    I have a really noob question:
    I have installed XF at mydomain.com/forum/
    My MyBB is installed at mydomain.com
    What is the easiest way to remove MyBB and make XF the index page when someone enters mydomain.com?

    Btw, the MyBB importer worked very well. Only problem is that the [attachment] tags dont work properly.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Why not create an /archive directory, move the MyBB forum to it and move the XenForo installation to the root?
     
  11. Jens1986

    Jens1986 Active Member

    Ok, so I can just drag and drop the whole xenforo installation in my FTP-client and it will work? I dont have to change anything in settings etc.?
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    You need to update the Board URL in the ACP Options.
     
  13. Jens1986

    Jens1986 Active Member

    I have a small question;
    When I search my forum none of the old posts comes up in results. Any fix for this?
     
  14. Mike

    Mike XenForo Developer Staff Member

    You need to rebuild the search index (should have been mentioned when the import completed.) Tools > Rebuild Caches.
     
    Jens1986 likes this.
  15. Jens1986

    Jens1986 Active Member

    Works like a charm now. From coming from a free forum software to this (first time I have bought a license) I have to say the support is way better then I expected. Thank you! :)
     

Share This Page