1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue Import template fails using Apache on Windows

Discussion in 'Resolved Bug Reports' started by sonnb, Sep 2, 2015.

  1. sonnb

    sonnb Well-Known Member

    I am not sure if there is a workaround for this but ideally it should be stated in the documentation.

    I am using Windows as development environment. When I try to upgrade/rebuild master data, XF is not able to import all the templates, it will stop at the 29th template.

    It fails in this part:
    'style_id' => 0,
    'title' => $templateName,
    'template' => XenForo_Helper_DevelopmentXml::processSimpleXmlCdata($template),
    'addon_id' => $addOnId,
    'version_id' => (int)$template['version_id'],
    'version_string' => (string)$template['version_string']
    Apache will be crashed and automatically restarted.
    I searched the web and found the issue is because of the "long regular expressions in PHP" which is because of this part:
    public static function processSimpleXmlCdata($cdata)
    This could be solved by increasing ThreadStackSize by adding following line to httpd.conf
    <IfModule mpm_winnt_module>
       ThreadStackSize 8000000
    There is also a bug report regarding this Apache exit code: PHP :: Bug #29107 :: Parent: child process exited with status 3221225725

    If there is no workaround, I hope it could be mentioned in the Documentation of XF.
  2. Mike

    Mike XenForo Developer Staff Member

    That's not a regular expression though.

    I would note that plenty of people use Windows and Apache for development without issues. There may be specific configurations you need to make if you're using an uncommon setup though (mpm_winnt isn't something I've ever seen used).
  3. sonnb

    sonnb Well-Known Member

    I use XAMPP with default configuration. It also happens when I upgrade the addon's xml - sometime the templates are not being updated. I think it is helpful in case someone face the same issue. Thanks for your patient.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I use XAMPP on Windows 7 without issue.
  5. sonnb

    sonnb Well-Known Member

    Thanks for your information. I am not sure the case but surely it is the part I have posted above. Just want to put it here in case someone search for it.
  6. Chris D

    Chris D XenForo Developer Staff Member

    This might be what @Jake B experiences with the blank templates which don't get compiled. In the cases I've seen so far, the common link has been XAMPP.

    FWIW - I never had a good time with WAMP or XAMPP. I used Zend Server for around a year. They gave away a free 1 year dev license to users of their previous (no longer available) free community edition. In recent months, I began to use Bitnami stacks:

    WAMP Stack Cloud Hosting, WAMP Stack Hosting - Installers and VM
    MAMP Stack Cloud Hosting, MAMP Stack Hosting - Installers and VM

    Actually in recent weeks I've been running a stack through a pre-configured Ubuntu box on Vagrant. Files are shared between host and guest machine using NFS which is a doddle to set up with Vagrant (though does need a plugin for Windows support).
  7. sonnb

    sonnb Well-Known Member

    That is the case. I used to get blank templates while was trying to upgrade add-ons with big XML files. Thanks for your information about Stack.
  8. CoZmicShReddeR

    CoZmicShReddeR Active Member

    OMG I tried this it helped me! I am using Windows Server 2008 Dual Xeon Quad Core 30GB Ram. Would like to state I had the issue with Wamp then switched to XAMPP same issue!

    So far since I added the coding @sonnb suggested to my httpd.conf the issue seems to have went away but will not truly know until I have updated a few more addons...

    <IfModule mpm_winnt_module>
       ThreadStackSize 8000000
  9. sonnb

    sonnb Well-Known Member

    I am happy to see it works for you. It is the most annoying issue which kept happening for a long time until I post this thread.
    CoZmicShReddeR likes this.
  10. CoZmicShReddeR

    CoZmicShReddeR Active Member

    Yep, so far I have updated several known addons that caused the white screens in options and all have been compiled properly! On another note it seems a lot of peeps were recommend I switch to another host because of this and I just want to say I host my own server at a local Data center and I love challenges but I also love short cuts and this was one that most likely saved me from alienating myself from xenForo!

Share This Page