Import Problems: Users

mochito

Member
Hi,

i still can't import users from old vb 3.8.6

the following "error" occurred and ends in endless try on the same user :/
----
Import Data: vBulletin 3.7/3.8

Import Users... 993 / 1398"
---
When i change the user-id manually it goes on with import, so i think there
must be somewhere else than in vb_user a problem...

edit: username don't have any special characters or commas on it

gtx, juergen
 

mochito

Member
Hi,
i've changed directly (online) in mysql the user_id in vb_user.

set user_id = 994 where user_id = 993

directly after this, user import goes on to the next users.

So, thats why i think its checking something else in another table that produce this error.

gtx, juergen
 

Jerry

Well-known member
Stuck on the same spot. Any hints on how to debug this? Our db was heavily modified during forum's lifetime, but i think everything should be fixable :rolleyes:
That rarely helps, though as long as all the orgional fields are there then the fix to the standard importer will work, as it will just ignore the extra fields.
 

mochito

Member
So,

slowly i get a little bit disappointed.
I've checked a lot of things, but i can't see a difference between other users.

gtx, juergen
 

mochito

Member
update:
the importer always trys to import 100 users (only users and groups, but not the avatars!).
If i change the userid it selects the next one.
But always it stucks and make a loop with "Import Users... 993 / 1398"and nothing happens anymore.

gtx, juergen
 

mochito

Member
Hi.

Again i try to make a import from a backup-database, so i deleted a lot of users and had around 30 user left in vb_user.
But: no changes - importer stucks while user-import, the same loop (with "limited" users, only 30 users left) coming up.


Any help from developer team requested, please.

gtx, juergen
 

Krochinzky

Member
Are you using Chrome or Safari? if so i'd try using firefox as there is a known issue with the xenforo install javascript with webkit browsers.
 

Decent60

Well-known member
Hi.

Again i try to make a import from a backup-database, so i deleted a lot of users and had around 30 user left in vb_user.
But: no changes - importer stucks while user-import, the same loop (with "limited" users, only 30 users left) coming up.


Any help from developer team requested, please.

gtx, juergen
Have you tried optimizing the database prior to importing?
I know with the users table there isn't much to optimize but sometime in the table could be just misplaced.
 

mochito

Member
- Optimazing DB - yes, done manually a lot of times, also copying db to a different db :(

- Debug mode - brings no more information

Here's the "debug-log":
Page Time: 0.3663s

Memory: 4.6523 MB (Peak: 5.1264 MB)

Queries (0, time: 0.0000s, 0.0%)

Included Files (71, XenForo Classes: 45)

  1. admin.php
  2. library/XenForo/Autoloader.php
  3. library/XenForo/Application.php
  4. library/Zend/Registry.php
  5. library/Lgpl/utf8.php
  6. library/Zend/Config.php
  7. library/config.php
  8. library/XenForo/FrontController.php
  9. library/XenForo/Dependencies/Admin.php
  10. library/XenForo/Dependencies/Abstract.php
  11. library/Zend/Controller/Request/Http.php
  12. library/Zend/Controller/Request/Abstract.php
  13. library/Zend/Uri.php
  14. library/Zend/Controller/Response/Http.php
  15. library/Zend/Controller/Response/Abstract.php
  16. library/XenForo/Model.php
  17. library/XenForo/Model/DataRegistry.php
  18. library/XenForo/CodeEvent.php
  19. library/Zend/Cache.php
  20. library/Zend/Cache/Backend/File.php
  21. library/Zend/Cache/Backend/ExtendedInterface.php
  22. library/Zend/Cache/Backend/Interface.php
  23. library/Zend/Cache/Backend.php
  24. library/Zend/Cache/Core.php
  25. library/Zend/Db.php
  26. library/Zend/Db/Adapter/Mysqli.php
  27. library/Zend/Db/Adapter/Abstract.php
  28. library/Zend/Db/Select.php
  29. library/Zend/Db/Expr.php
  30. library/Zend/Db/Profiler.php
  31. library/Zend/Db/Statement/Mysqli.php
  32. library/Zend/Db/Statement.php
  33. library/Zend/Db/Statement/Interface.php
  34. library/Zend/Db/Profiler/Query.php
  35. library/XenForo/Options.php
  36. library/XenForo/Link.php
  37. library/XenForo/Router.php
  38. library/XenForo/Route/ResponseSuffix.php
  39. library/XenForo/Route/Interface.php
  40. library/XenForo/Route/Prefix.php
  41. library/XenForo/Route/PrefixAdmin/Import.php
  42. library/XenForo/RouteMatch.php
  43. library/XenForo/ControllerAdmin/Import.php
  44. library/XenForo/ControllerAdmin/Abstract.php
  45. library/XenForo/Controller.php
  46. library/XenForo/Input.php
  47. library/XenForo/Session.php
  48. library/XenForo/Visitor.php
  49. library/XenForo/Model/User.php
  50. library/XenForo/Permission.php
  51. library/XenForo/Phrase.php
  52. library/XenForo/Locale.php
  53. library/XenForo/Install/Model/Install.php
  54. library/XenForo/Helper/File.php
  55. library/XenForo/Model/Import.php
  56. library/XenForo/ImportSession.php
  57. library/XenForo/Importer/vBulletin4.php
  58. library/XenForo/Importer/Abstract.php
  59. library/XenForo/Db.php
  60. library/XenForo/ControllerResponse/View.php
  61. library/XenForo/ControllerResponse/Abstract.php
  62. library/XenForo/ViewRenderer/HtmlAdmin.php
  63. library/XenForo/ViewRenderer/Abstract.php
  64. library/XenForo/Template/Admin.php
  65. library/XenForo/Template/Abstract.php
  66. library/XenForo/Template/Helper/Core.php
  67. library/XenForo/ViewAdmin/Base.php
  68. library/XenForo/View.php
  69. library/XenForo/Model/AdminNavigation.php
  70. library/XenForo/Debug.php
  71. library/XenForo/Route/PrefixAdmin/Development.php
 

Decent60

Well-known member
I didn't have any problems importing 3.6k from database to database (vB3.8.4). Only other thing I could think of to do is to start with a clean XenForo installation and try again (you've prolly have done this already)
 

mochito

Member
Installed beta 2 - same problem with import :(((((((((((((((((((((((((((((((

Still in loop.

Import Users... 70.63%
 

Mike

XenForo developer
Staff member
I would need access to your source database (and possibly the server you're doing the import, as that may be significant) to debug this issue.
 
Top