1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Import issues

Discussion in 'XenForo Questions and Support' started by Jo., May 2, 2011.

  1. Jo.

    Jo. Well-Known Member

    I'm only just posting this now as I've been away for a few days...

    We did an import of a vB board to our xf board and have had a couple of problems. First of all there were forums that weren't merged - they had the same names etc. but they just ended up being turned into separate forums with the same name and category names. Also, not all the forums showed up after the import was completed, and we spent ages trying to figure out why. We figured it might just have been a permissions problem but then we got our heads in knots trying to figure out how to set the permissions for all the different usergroups we had after the import (members ended up with access to places they shouldn't have too, which was a problem to figure out as well)...

    We came to the conclusion that having so many usergroups was probably unnecessary since access isn't dictated by usergroups, so we decided to get rid of any unnecessary usergroups... but, we didn't realise that deleting a usergroup would delete any member accounts that have those usergroups as primary... so now we've lost a load of user accounts and we really need to get them back.

    Is there a way to do that without having to re-do the import all over again? We could really use some help as we're pretty much out of our depth and really confused about how to get access sorted out in the way we need to (there's no way that we can see, of seeing what access each member has, which is really frustrating if you've got a LOT of private forums...)

    If any of you can help us out, we'd seriously appreciate it, cos we're all a bit gutted and frustrated and confused about the whole thing lol.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Deleting a user group doesn't delete the members. At least it didn't during my testing anyway.

    As for the permissions issues, there really is no easy solution, especially if you have a complex set up with lots of user groups and private/specific forums.

    I suspect that a lot of the forums didn't appear as you didn't have permission to access them.
    Did the nodes appear in the ACP?

    You only really have a few options:
    1. Import the database as it is and set up/confirm all the users, user groups and node permissions.
    2. Reset all the users, groups and permissions before the import and set them up from scratch afterwards.

    Other than that, I can't really suggest what else can be done.
     
  3. Jo.

    Jo. Well-Known Member

    Hmm, well that's odd then because those users who had the deleted usergroups as primary aren't showing up... so either they didn't import properly or something else is going on cos they're not there...

    Yeah the nodes were there in the acp, but we couldn't figure out how to give them to the right people and how to be able to check who has access to what without going through every private node's permissions to see who has access... which is a really long-winded and frustrating way to do it (If you know of a way to be able to quickly and easily see which members have access to a particular node, please let me know because we're really struggling without the ability to do that!).

    If you've got a couple of thousand members, it's going to take a loooooong time to sort out each of their node permissions individually... and then to go through them all to check who's got access to what. How would you know if someone has access to somewhere they shouldn't? It's really confusing me lol.

    So basically, we need to do the import over again right?

    edit: Also, how come the nodes with the same names as those we were importing didn't merge?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Did you try searching for those members in the ACP or front end?
    If the search returns no results then obviously they weren't imported so that needs to be investigated.

    Only users with duplicate names are able to be merged.

    Everything else is duplicated, so if you import multiple times you'll end up with a lot of duplicated content.
    http://xenforo.com/help/importing/

    I can't really offer any more advice on setting up the users, groups and permissions.
    Unfortunately it's something that needs to be done after an import and there is no quick and easy solution for complex set-ups.
     
  5. Jo.

    Jo. Well-Known Member

    In the acp... I just checked again and it seems like not all of them are gone but some of them definitely are, and it's assigned some of the posts made by the missing members to members that are showing up... it's all a bit scrambled lol.

    Oh, okay, so you can't create a new forum on the xf forum with the same details as one on the vB forum so you can merge a forum on the xf one with the same name on the vB one? (sorry if I didn't say that in a way that made much sense lol). We thought that forums with the same name would merge into one?
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Correct. They don't merge.
     

Share This Page