• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Import from vB 3.6?

#1
I've got an ancient version of vB running, for various reasons.

Is it possible to import from vB 3.6? I've tried running the importer (which just specifies 3.7 / 3.8) but when I press "import user groups" I just get
A server error occurred. Please try again later.
which I'm guessing means it won't work.

I do have a copy of 3.8.2 to upgrade to if I want, but am reluctant to at the moment as it will totally break my forum's styles and I'd like to make sure XenForo works well before closing off the old boards.
 

Brogan

XenForo moderator
Staff member
#3
I'd like to make sure XenForo works well before closing off the old boards.
Bear in mind that XenForo is still Beta and it isn't recommended to run a live site on it.

Having said that, plenty of people are, including this site so if you are comfortable with doing the same then there's no reason why you can't.
 

Dean

Well-known member
#4
make a backup, do an upgrade on a test forum, then import to xenforo.
This would be my approach.

Even if you have no plans to go live any time soon there could be much time spent in gathering feedback from your users, and all the other things that go into changing software.
 

Paul M

Well-known member
#5
Is it possible to import from vB 3.6? I've tried running the importer (which just specifies 3.7 / 3.8) but when I press "import user groups" I just get

which I'm guessing means it won't work.
It's not possible without a small edit to the vb3 importer - the reason being it tries to read the visitor message permissions, which don't exist in vb 3.5 and 3.6.