XF 1.4 Images Alt tag for imported rss, question

Anton_Bodryachkom

Active member
Hello forum , for some reason AltTag for images importing incorrectly . here is structure of my rss file

This is just an Example how i structured rss file:

<item>
<title>Top-Rated BUCKHEAD!!</title>
<description><![CDATA[<br />
UPSCALE BUCKHEAD !! **WEEKDAYS/NIGHTS WEEKENDS!!**

<a href='http://www.site.com' target=_blank><img width="50%" height="auto" title="Top-Rated BUCKHEAD!!" alt="Top-Rated BUCKHEAD!!" src='http://site.com/k6a9664psdcroppedcompressed.jpg' border=0></a><br />
<br />]]></description>
<link>http://www.site.com/link/link.asp?ID=69662</link><keyword>Top-Rated BUCKHEAD!!</keyword>
</item>
So when i import this type of rss , all imported correctly (no keyword , but I already know that forum imported dont read or import keywords ) , but alt tag , when i sourse imported thread it looks like this



blockquote class="messageText SelectQuoteContainer ugc baseHtml">

UPSCALE BUCKHEAD !! **WEEKDAYS/NIGHTS WEEKENDS!!** <br />
<div style="text-align: left"><br />
<a href="http://site.com/k6a9664psdcroppedcompressed.jpg" class="internalLink"><br />
<img src="http://site.com/k6a9664psdcroppedcompressed.jpg" class="bbCodeImage LbImage" alt="[&#x200B;IMG]" data-url="http://site.com/k6a9664psdcroppedcompressed.jpg" /></a><br />
&#8203;</div><br />
<a href="http://site.com/k6a9664psdcroppedcompressed.jpg" target="_blank" class="externalLink" rel="nofollow">See my ad...</a>
<div class="messageTextEndMarker">&nbsp;</div>
</blockquote>

i have no idea where this alt tag getting from . plz help , how to correctly show alttag

thank you
 

Mike

XenForo developer
Staff member
The HTML is converted to BB code. The BB code does not support alt attributes.
 

Mike

XenForo developer
Staff member
You would need to modify the code to change that, but it's not "generated" from anywhere. It's just what every image has as an alt.
 
Top