1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 I Share an IP With EVERY User

Discussion in 'Troubleshooting and Problems' started by taylor_smith, May 7, 2014.

  1. taylor_smith

    taylor_smith Well-Known Member

    In the ACP, you can check a user's IP to see if it matches any other users' IP.

    I share an IP with literally every other user. My "IP Addresses" tab shows dozens-to-hundreds of different IPs every day. I only access my account from three locations, and never via proxy or ad blocker (no browser plugins installed).

    What's the deal?
     
  2. Mike

    Mike XenForo Developer Staff Member

    What's the IP? If you use a proxy service like CloudFlare or a load balancer, it may well be that IP. (If that's the case, you need to make a change in config.php or your webserver configuration to have it report the original IP.)
     
  3. taylor_smith

    taylor_smith Well-Known Member

    It's dozens-to-hundreds of different ones every day. Not sure I should list them here, but they're all different. It's only me--none of the other super admins.

    No CloudFlare (any longer). I'll double check config.php.
     
  4. Mike

    Mike XenForo Developer Staff Member

    If it's all over the place, it could be related to an add-on doing something that causes an IP to be logged (posting a message, as an example, though many other things).
     
  5. Jeremy P

    Jeremy P Well-Known Member

    Probably an addon.

    When XenForo first came out I created an addon to welcome new users with a conversation. Not too much later I realized I also shared an IP with every user, because the messages were being generated by them. I had to change the addon not to record IP addresses while creating that conversation.
     
  6. taylor_smith

    taylor_smith Well-Known Member

    I use an addon like that. @borbole's new user welcome addon. Maybe that's it. How'd you adjust the addon?
     
  7. Jeremy P

    Jeremy P Well-Known Member

    There's some flag in the datawriter. I don't use the addon anymore but I will dig it up and edit this post.

    Edit:

    The addon should include the following:
    PHP:
    $messageDw->setOption(XenForo_DataWriter_ConversationMessage::OPTION_SET_IP_ADDRESSfalse);
    You can pass that on to the author, who should know how to work it into his addon :)
     
    Last edited: May 7, 2014
    AndyB and taylor_smith like this.

Share This Page