• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 I can't view reports but my moderators can

#1
Hi, I (an administrator) can't view reports (open or closed) but my moderators can. Is there an option I need to set somewhere in order to get this to work?

Thanks.
 

Martok

Well-known member
#3
To view reported items, you must explicitly be made a moderator in the ACP.

ACP > Users > Moderators

In addition:

  • The Moderator Bar is visible for all users who are made moderators. However, the Moderation Queue and Reported Items are only accessible with the following moderator permissions enabled:
    • Moderation Queue - View moderated threads / posts and Delete thread by anyone and Edit post by anyone.
    • Reported Items - Delete post by anyone or Edit post by anyone.
https://xenforo.com/help/moderators/
 
#5
I went to that page and resaved it (even though all were checked) and after that it worked. Front end moderation permissions appeared to be imported from vBulletin just fine, so I don't need to change anything there.
 

Brogan

XenForo moderator
Staff member
#7
User groups are primarily for permissions and styling.

Specific states such as moderator and administrator are in addition to those.
 
#8
I've been told there is supposed to be a sidepanel on the reports area with buttons to close reports, etc. Why would this not be displaying? Any ideas? I do have the Widget framework addon installed and am using a custom side bar, but if I need to set something to enable the moderation side bar, please let me know.
 

melbo

Well-known member
#10
If you don't have any reports, there's nothing to see. Go report something and see if it shows up. I have widget framework but didn't have to do anything for the report functions.
 
#11
Where should it display by default? I don't see the options anywhere.

(And I do have reported posts in there. We just can't close them or do anything but reply.)
 

Martok

Well-known member
#12
Where should it display by default? I don't see the options anywhere.
There are no options, the report centre sidebar is just there.

As you're using Widget Framework, I suspect you are using the "All" position in the Clear Sidebar widget and possibly other widgets too. Don't use the "All" position as it carries out the action everywhere, including in the Report Centre, hence making the Report Centre sidebar disappear. You should use named templates instead eg forum_list. If you need for further guidance on using template names and hooks,you can post about these in the Widget Framework discussion thread.