1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I can not login to my account for long time?

Discussion in 'Troubleshooting and Problems' started by ang1el, Mar 6, 2011.

  1. ang1el

    ang1el Member

    I have set up xF. When a user log in to the page, it shows log in for that page but when s/he visit to next page it doesn't show log in.

    Is this a bug?

    Thanks for suggestion in advance.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I'm not quite sure I understand the problem.

    Is the user being logged out when navigating to another page?
    Are they blocking cookies in their browser?
  3. ang1el

    ang1el Member

    Cookies has not been blocked, I checked with two different computer.

    Sometime its very difficult to log in for e.g. it doesn't show incorrect user or pw, it keeps displaying log in page and if it get log in when navigating to another page, it doesn't display the user i.e. user is not seen log in.
  4. Dean

    Dean Well-Known Member

    Someone logs into your forum, it shows them logged in, then when they go to another page on your forum they are no longer logged in?
  5. Brogan

    Brogan XenForo Moderator Staff Member

    It's not even possible to log in unless the "Stay logged in" checkbox is selected - I had a look at it earlier, as did Kier.

    Seems to be a server issue so the OP has gone back to the host to see what they can do about it.
  6. Dean

    Dean Well-Known Member

    I just logged out on xf.com, then logged back in without the Stay logged in checked.. worked for me.

  7. Brogan

    Brogan XenForo Moderator Staff Member

    I was referring to the OP's installation.
  8. Ray

    Ray Active Member

    If you are using both www and non-www, that might be the issue.
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's what I was thinking. The subdomain is relevant here. All internal links on the forum are consistent with respect to the subdomain. But perhaps you are clicking a link that is not consistent.

    You can use some rewrite rules in a .htaccess file to enforce one URL:

  10. Brogan

    Brogan XenForo Moderator Staff Member

    Mike has managed to resolve this.

    The server was behind several proxies which caused the reported client IP to change on every page view.
    This invalidates the session, for security.

    Mike added code to work around this to config.php.
  11. ang1el

    ang1el Member

    Thanks Borgan, and thanks to Mike and entire team who were so energetic to help me out.

    I am proud to say that I did the best decision to have xenForo, and you all have proved it out by working so hard to fix this issue.

    Thank you all.
    Dean and Mike like this.
  12. Carlos

    Carlos Well-Known Member

    Quite the team at xenforo. I only wish I had a team like that.

Share This Page