1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 https working, but not on all pages why>

Discussion in 'Troubleshooting and Problems' started by phtvs, Jan 6, 2016.

  1. phtvs

    phtvs Member

    Hi,

    On our forum everything is working with ssl/https. But in some threads we get a mixed content warning. The only problem is that there is no mixed content. Even in plain text topics, the mixed content warning is showing in the browser.

    So I have tested it and made a new topic, copy&paste the text from the other topic into this one. And now I dont get the mixed content warming.
    How is it possible? the topic and everything in it is exactly the same.....

    Just 2 add-on (these cant be the problem I gues)
    - Digital Point Spy
    - Ajax chat

    Please help.

    Thanks in advance!
     
  2. melbo

    melbo Well-Known Member

    Link?
     
  3. James

    James Well-Known Member

    Mixed content warnings will be if something is being served over http. You sure no images link http or any linked scripts are using absolute http urls?
     
  4. phtvs

    phtvs Member

  5. phtvs

    phtvs Member

    Can it be the mentions causing this?
    @James
    Or maybe the signature of some member with a link in it?
     
  6. melbo

    melbo Well-Known Member

    I see no mixed content warnings from a guests view.
    I had to turn on image proxy and track down a few other things to get mine working.

    On a page with mixed content, view page source and search for http: and see if anything is buried in there.
     
    phtvs likes this.
  7. phtvs

    phtvs Member

    I just found it. It was a smilie that was causing the problem!

    Thank you!
     
    melbo and James like this.
  8. James

    James Well-Known Member

    Signatures can cause it especially if linked to external sites. Most members don't know to use https. I'd search the page source as above for anything prefixed http: and see if it's something you can sort internally or maybe you need to disable images in signatures unless served over https.
     
    phtvs likes this.
  9. melbo

    melbo Well-Known Member

    yep. We found a couple smilies that had been added as external links too :)
     
  10. phtvs

    phtvs Member

    sometimes the solution of a problem is so simple. :)
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    The other issue.. turn on your image proxy in the ACP of XenForo.
     
  12. phtvs

    phtvs Member

    Thank you but that was already on ;-)
     

Share This Page