1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HTTP 500 on Import, under Windows

Discussion in 'Troubleshooting and Problems' started by Shamil, Oct 27, 2010.

  1. Shamil

    Shamil Well-Known Member

    I seem to be having an issue trying to import data from a database.

    Running XenForo 1.0, Beta 2 on Windows Server 2008 R2, MySQL 5.5, PHP 5.3.3

    So, I enter the database values on the Configure Importer page. I am using the local root to login, and I've entered the host as On submitting the form, I am faced with a HTTP 500.

    Unfortunately, nothing is sent to the php log, so I don't know what's going on.

    WinCache datastore had been disabled. No plugins/addons installed.
  2. Blandt

    Blandt Well-Known Member

    So the xenforo is installed correctly ? what are you trying to import ?

    by default IIS error log is in c:\inetpub\logs\logfile

    Check that and here is the link for each error cause : http://support.microsoft.com/kb/943891
  3. Blandt

    Blandt Well-Known Member

    Did you get any errors in your log ? Please post here
  4. Shamil

    Shamil Well-Known Member

    That IIS log file only logs the visits/page. I'm trying to import a vB forum into XenForo. No errors in the log file

    Edit: I forgot about XenForo's internal system though...

    Erro : Undefined index: charset library\XenForo\Importer\vBulletin.php:81 A moment ago

    Error Info

    ErrorException: Undefined index: charset - library\XenForo\Importer\vBulletin.php:81
    Generated by: Shamil, 1 minute ago
    Stack Trace

    #0 C:\inetpub\Hostcule\library\XenForo\Importer\vBulletin.php(81): XenForo_Application::handlePhpError(8, 'Undefined index...', 'C:\inetpub\Host...', 81, Array)
    #1 C:\inetpub\Hostcule\library\XenForo\Importer\vBulletin.php(29): XenForo_Importer_vBulletin->validateConfiguration(Array)
    #2 C:\inetpub\Hostcule\library\XenForo\ControllerAdmin\Import.php(56): XenForo_Importer_vBulletin->configure(Object(XenForo_ControllerAdmin_Import), Array)
    #3 C:\inetpub\Hostcule\library\XenForo\FrontController.php(303): XenForo_ControllerAdmin_Import->actionConfig()
    #4 C:\inetpub\Hostcule\library\XenForo\FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 C:\inetpub\Hostcule\admin.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State

    array(3) {
    ["url"] => string(47) "admin.php?import/config"
    ["_GET"] => array(1) {
    ["import/config"] => string(0) ""
    ["_POST"] => array(3) {
    ["config"] => array(1) {
    ["db"] => array(6) {
    ["host"] => string(9) ""
    ["port"] => string(4) "3306"
    ["username"] => string(4) "root"
    ["password"] => string(7) "password"
    ["dbname"] => string(13) "vbforum"
    ["prefix"] => string(0) ""
    ["importer"] => string(9) "vBulletin"
    ["_xfToken"] => string(53) "1,1288202791,f5fba9f8e44d108d3b422f33a1ee696e839d310f"

    Seriously, can XenForo stop putting out things in the header? I can't actually tell what's going on :/
  5. Mike

    Mike XenForo Developer Staff Member

    Did you happen to start an import on beta 1 and move to beta 2 then? I could see that causing it. Otherwise, the only other cause I could think of would be having the admin templates from beta 1 - re-running the upgrade steps should catch that.
  6. Blandt

    Blandt Well-Known Member

    If you got a 500 internal error, IIS should spit out an error in the log folder

    In any case ... check your vB database : "Undefined index: charset" rebuild it and try again
  7. Shamil

    Shamil Well-Known Member

    Nope. Just started it. I'll rerun the upgrade steps.

    Let's see
  8. Shamil

    Shamil Well-Known Member

    Update: Nope. Even tried a fresh install of XenForo.

    Update: Tried commenting out the references to the charset. So far, it's importing the data. On step: Import Forums...

    Update: On the complete import step, so it's rebuilding the cache. Looks like a lot of "An error occurred or the request was stopped." messages coming out from the user cache purge. I can't tell what it is, since there's nothing in the logs to indicate what error occurred. Maybe timeout? Rebuilding threads though.

    Update: Threads 2500? There's only 2,100 threads there :eek:
  9. Blandt

    Blandt Well-Known Member

    hahahaha vB databases are weired .. I suspect the problem is from the source :D .... optimize it over and over :D
  10. Shamil

    Shamil Well-Known Member

    Tried that. Import completed. Permissions issues. The administrator has no privileges to post.

Share This Page