1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 htaccess problem

Discussion in 'Troubleshooting and Problems' started by Roberto Bilić, Jan 25, 2013.

  1. Roberto Bilić

    Roberto Bilić Active Member

    I try force www with .htaccess, but now cannot access to my board. Redirect me to the blog. Try mv .htaccess to htaccess.txt, disable cache in config and delete cache files, disable Cloudflare, but still cannot access to my board. Direct access to post with post url work fine, but forum root dont work.

    Forum url: http://www.hedonist385.in/forum
    Blog url: http://www.hedonist385.in/
    Direct access: http://www.hedonist385.in/forum/forums/smještajni-kapaciteti.38/

    Blog software: wordpress
    public_html .htaccess: http://pastebin.com/nQasYfhk

    Forum .htaccess
    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /forum
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Before this edit .htaccess that work fine
     
  2. Roberto Bilić

    Roberto Bilić Active Member

    Resolved. Browser problem (Firefox 18.0.1 @ linux Mint)
     
    Jake Bunce likes this.

Share This Page