1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to turn off Tapatalk alerts on iPhone?

Discussion in 'Troubleshooting and Problems' started by BGL, Oct 10, 2012.

  1. BGL

    BGL Well-Known Member

    With the new IOS6, Tapatalk annoyingly keeps posting alerts on my phone about forums I follow using Tapatalk.

    I looked at Settings/Notifications where all such controls are supposed to be. TapaTalk is listed there under "Not in Notification Center" and all the settings there are set to OFF.

    In Tapatalk main screen on Settings, Push Notifications are set to OFF and email notifications are set to OFF.

    Is there another area I'm missing to stop the Tapatalk notifications?
     
    8thos likes this.
  2. BGL

    BGL Well-Known Member

    Still no solution. I get the TapaTalk alerts in the iPhone despite General/Notifications and TapaTalk has no notifications activated.

    It looks like TapaTalk and Gmail for that matter are not affected by Notification settings on the IOS iPhone despite the notice that all such settings are there for the iPhone.

    I like Tapatalk but I'm about to delete it from the iPhone for its bad behavior.
     
  3. DRE

    DRE Well-Known Member

    Yeah that's annoying as hell so I no longer use it.
     
  4. BGL

    BGL Well-Known Member

    But why can't we turn off the Tapatalk alerts?
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I am not a mobile computing person so I can't look into this myself. Have you tried posting on Tapatalk's support forum?

    http://support.tapatalk.com/
     
    Chris D likes this.
  6. Chris D

    Chris D XenForo Developer Staff Member

    Jake Bunce likes this.
  7. BGL

    BGL Well-Known Member

    Unfortunately TapaTalk is slow to non-responsive on many issues, this is one of them. I was hoping there was some IOS6 setting I was missing. I would consider it more of an IOS6 issue as Apple says that ALL notification settings are under General/Notifications but clearly that's not the case and rogue apps like Tapatalk ignore those settings. But I was hoping there was a setting I was missing.
     
  8. melbo

    melbo Well-Known Member

    I have Push turned OFF on my forum and OFF on my Tapatalk (phone) but certain threads (not all) continue to push through to my phone.
     
  9. BGL

    BGL Well-Known Member

    It's first and foremost an IOS issue. If Apple states that user controls ALL notifications vis the iPhone's "Notifications" settings then that is where the controls should be and they should work. It is a problem if software developers like TapaTalk can ignore the users phone controls. Tapatalk is losing customers by being a rouge app regarding notifications as we see from the complaints here and on the forums.
     
    melbo likes this.
  10. BGL

    BGL Well-Known Member

    I think I found the solution. A "pilot error" solution...with Apple as the co-pilot.

    In Settings/Notifications even if the application is "Off" you have to set the alert panel under it to "None" because "Off" doesn't really mean "Off".
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    Oh. I see what's happened. You have set Notification Center to off fpr Tapatalk. That is the list of notifications you get if you swipe down from the top of the screen.

    Turning that off wouldn't disable the Notifications themselves. They would just stop them appearing in that list. As you've rightly discovered you wanted to turn the alerts off.

    Guess it makes sense :)
     
    Jake Bunce likes this.
  12. BGL

    BGL Well-Known Member

    Of course not. One would be a fool to think turning off Notifications for an application actually turned off notifications for an applications especially when told that all notifications are handled by Notifications. It would be madness.
    In an Alice in Wonderland way it makes perfect sense.
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    It does make sense.

    There is a thing called the Notification Center:

    image.jpg

    You can stop apps from showing in here (which is what you did with Tapatalk) while still allowing Alerts to be displayed.

    So you could have Tapatalk notifications displayed in the notification center without alerts or alerts without notification center or off completely.
     
    Jake Bunce likes this.
  14. BGL

    BGL Well-Known Member

    Where ALL NOTIFICATIONS ARE MANAGED per Apple.
    Ah...of course...Alerts are not Notifications in any way. Gotcha.
    Makes perfect sense...I turn off all Notifications for an app and still get Notifications...er..."Alerts" which are not notifications in some alternate universe.

    1. Turn off Notifications for an App...Notifications are turned off.
    2. Turn on Notifications for an App...Choose which notifications to display.

    Nah...that's too easy and common sense.

    There were at least 10 different threads on this on the Tapatalk forum so lots of users were RTFM and turning off all notifications expecting all notifications to be turned off. Same is no doubt true for other apps so clearly Apple got it wrong.

    What was interesting is Tapatalk didn't know what was going on either and would suggest resetting the phone or deleting and reinstalling Tapatalk on the phone or iPad.

    Off should mean Off.
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    I'm afraid you're still misunderstanding.

    Notifications are managed in Settings > Notifications.

    Notification Center is where notifications are displayed. You do not manage notifications in the Notification Center.

    This is one of the types of alerts you can have, e.g from the Mail app:

    image.jpg

    This is what that alert looks like in the Notification Center:

    image.jpg

    You turned off only one of these where you needed to turn off both. The granularity is actually quite convenient.

    I have only Mail displayed in the Notification Center so I have easy access to them. Everything else such as SMS I have alerts for but I do not display them in the Notification Center.

    Off does mean off. When you turn the correct things off.
     
    Jake Bunce likes this.
  16. DRE

    DRE Well-Known Member

    I dislike Tapatalk so much, that I turned off the notifier.

    tapatalk turned off.jpg
     
  17. Gambleru

    Gambleru Member

    Care to share the how-to?
     
  18. DRE

    DRE Well-Known Member

Share This Page