1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 How to reset sessions ?

Discussion in 'XenForo Questions and Support' started by Recep Baltaş, Feb 3, 2015.

  1. Recep Baltaş

    Recep Baltaş Well-Known Member

    Hi, we have started using Sucuri service but they have made a "little" mistake of enabling fully caching and this led to users finding themselves in other people's accounts.

    We have disabled caching and the problem seems to be solved but I want to make sure by resetting sessions.

    How can I do that ?

    Thanks.
     
    Last edited: Feb 3, 2015
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You could truncate the session table, if that's what you mean.
     
  3. Recep Baltaş

    Recep Baltaş Well-Known Member

    I think yes. That is what I should do.
     
  4. Recep Baltaş

    Recep Baltaş Well-Known Member

    Truncated the tables but I am still logged in. Any idea ?

    I am admin. But I have also truncated Admin Sessions...

    //Let's change the cookie prefix.
     
    Last edited: Feb 4, 2015
  5. Mike

    Mike XenForo Developer Staff Member

    If you chose the "stay logged in" option, you don't depend on the session. There isn't a bulk way to invalidate that.
     
  6. Recep Baltaş

    Recep Baltaş Well-Known Member

    Last edited: Feb 4, 2015
  7. Mike

    Mike XenForo Developer Staff Member

    Well it will work by changing what XF reads, but it doesn't actually invalidate the old data. If someone has the old cookie value, they could still change the name on it and it'd work.
     
  8. Recep Baltaş

    Recep Baltaş Well-Known Member

    Since I am 100% sure that none of them know how to change it, it will work :)

    Do I have to provide a domain name ? How should it be ?

    Our web site:
    Code:
    https://www.technopat.net/
    Forum:
    Code:
    https://www.technopat.net/sosyal/
    PHP:
    $config['cookie'] = array(
        
    'prefix' => 'xft_',
        
    'path' => '/',
        
    'domain' => ''
    );
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    What you have above will work, unless that is your current prefix.
    In which case just change it to xf_.
     
    Recep Baltaş likes this.
  10. Recep Baltaş

    Recep Baltaş Well-Known Member

    If will be my new prefix. Thaks a lot.
     

Share This Page