1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to: only show custom style / user should not select default style ?

Discussion in 'Troubleshooting and Problems' started by erich37, Oct 25, 2010.

  1. erich37

    erich37 Well-Known Member

    I have created a new custom style.

    But currently it is possible for the user the choose both the default or my custom style, although I have disabled "Allow user selction" for my custom style.

    So what to do in order to have my custom style available only ?
    The user should not be able to select any style, I just want to have my custom style showing for the website.

    Do I need to delete the default style ?

    Many thanks,
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Just set your custom style as the default in the ACP.


    Then set the other style to not selectable by users.


    Don't forget as Admin you will have access to all styles, even if not selectable.
    cheeseshredder likes this.
  3. erich37

    erich37 Well-Known Member

    I actually just created a new style and changed a specific color.

    But I guess I have been logged in as Admin, so I could switch styles, although I have set my custom style as default. So that might have been the issue.

    I will try again to see if I can manage this.

    Anyway many thanks for your help, Brogan ! You are the best moderator over here !
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Just log out and browse your site as a guest.
    You'll see then which style is the default and which are available to choose.
  5. steven s

    steven s Well-Known Member

    Although I believe this is a bug.
    I have default unchecked and my style checked. A guest will see the style chooser and when they click on it have this option


    but if they click on either style, it is always the custom style.
    I would think if there is only one available, the chooser should not be visible or at least not list Use default style.
    Am I explaining this correctly?
  6. erich37

    erich37 Well-Known Member


    do you see your BavForums in the style-chooser when being logged out ?
    I need to check this tomorrow again, whether this also shows to guests or Admin only...... if it shows to guests even when default-style us unchecked, then it is a bug......
  7. Brogan

    Brogan XenForo Moderator Staff Member

    There's only one style there.
    The bavForums style is the default style.

    Although I see your point with regards to there only being one style available.
  8. erich37

    erich37 Well-Known Member

    I guess it is still showing as "style chooser" within the footer......should not be when there is only 1 style available.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Delete the default style and the style chooser will disappear.
    D37 likes this.
  10. steven s

    steven s Well-Known Member

    The image above is when clicking on style chooser as a guest.
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  12. erich37

    erich37 Well-Known Member

    I am not sure I want to delete the default style.... I want to keep it for reference.....
  13. Brogan

    Brogan XenForo Moderator Staff Member

    You can just create it again whenever you want by clicking on Create New Style.
  14. erich37

    erich37 Well-Known Member

    how do I change the background-color from grey to something else ?
    I have changed the background-color at the "Default Style", but it does not take the color I have selected.

    Do I need to create a new style in order to just change the background-color ?
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Do you mean the main background, either side of the forum?

    That's in Style Properties -> General -> HTML -> Background Color
    erich37 likes this.
  16. erich37

    erich37 Well-Known Member

    Hi Brogan,

    I mean the gry-colored page-background #F0F0F0
    I have tried to change this color at "Style Properties / Color Palette", but does not work.....
  17. Brogan

    Brogan XenForo Moderator Staff Member

    See my post above, that's the style property for that element.
    erich37 likes this.
  18. erich37

    erich37 Well-Known Member

    I have upgraded from XF Beta2 to XF Beta5 now and my custom background-color stayed the same, meaning it did not change on the software-upgrade which is fine.
    But now I wanted to change the background-color to some other color and only some portion of my background-color changed.
  19. Brogan

    Brogan XenForo Moderator Staff Member

    Any changes made in the ACP to the colour palette will affect all CSS elements which utilise that colour.
    If you've made edits to the template and/or CSS then this may not be the case.

    If you want to change the page background colour, go to Style Properties -> General -> HTML: Background Color

    Some templates may need reverting due to a small bug - see the full list here: http://xenforo.com/community/threads/xenforo-1-0-0-beta-4-released.8732/#post-120570

    You will need to reapply any edits you have made to those templates after reverting them.
    erich37 likes this.
  20. erich37

    erich37 Well-Known Member

    it is working fine actually, it was a mistake I have made by myself......
    thanks for your help!

Share This Page