• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 How to make https:// working :D

Exemption

Active member
#1
So I recently just purchased PostiveSSL from Namecheap and have it all working but can not get https:// and ect. working on my site. How do I make it so when people visit mysteriarealms.com is automatically places https:// in the url?

When I type now https://mysteriarealms.com I see this


Rather than this:
 

Rudy

Well-known member
#2
Not knowing which server you are running, you probably need some kind of redirect. In Apache you could do this in .htaccess or in the vhosts file, to rewrite all http to https. Someone who knows more about this can probably help.
 

Mouth

Well-known member
#3
How do I make it so when people visit mysteriarealms.com is automatically places https:// in the url?
/admin.php?options/list/basicBoard and ensure your 'Board URL' is https://
+ what @Rudy says above about ensuring your web server is set correctly for https, and http redirect to https if you want https only.
 

Exemption

Active member
#4
/admin.php?options/list/basicBoard and ensure your 'Board URL' is https://
+ what @Rudy says above about ensuring your web server is set correctly for https, and http redirect to https if you want https only.
I did the basic Board already. How do I do the second party making a http redirect to https? I was told to edit my .htaccess in public_html but this is what I have currently
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On
        RewriteCond %{HTTP_HOST} www.mysteriarealms.com$
        RewriteRule ^(.*)$ http://mysteriarealms.com$1 [R=301,L]

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Mike

XenForo developer
Staff member
#5
Are you running Apache? If so, you really shouldn't have to do anything (normally).

Are you using CloudFlare, perhaps with their flexible SSL?
 

Exemption

Active member
#6
Are you running Apache? If so, you really shouldn't have to do anything (normally).

Are you using CloudFlare, perhaps with their flexible SSL?
Seems that I fixed it, I was viewing my old website on my old hosts. Now I have this:

How do I fix this?
 

Exemption

Active member
#8
If you are referring to the insecure content, use the browser inspector and you will see why - there are many images being loaded from imgur via http.

Your site is also available at http and https - you should force it to https.
See point 20 of the FAQ here for how to do that: https://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180456
Alright I have forced https :D Now so to make it back to the green lock and all secured, I have to remove any imgur images?