• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 How to have forums at /forums and portal in root

Status
Not open for further replies.

Hornstar

Well-known member
#1
I have my forums in the forums directory. eg. mysite.com/forums

There seems to be several portals around, however how do I get the portal to load from mysite.com in the root?

I've tried changing Options > Basic Board Information > Index Page Route from forums/ to portal/
However I then have the portal loading from forums and the forums loading from forums/forums

I've tried moving forums to the root, and doing the above and even tho the portal and forums were now in the correct directory the thread links no longer had the same links, which I didn't want to keep.

So is there a way without moving the forums from the forums directory, to get a portal that is installed in the forums directory to load from the root at mysite.com ?
 

Floren

Well-known member
#4
I use this on our live site:
/library/XenResource/Listener/Template.php
Code:
            $extraTabs['resources'] = array(
                'title' => new XenForo_Phrase('home'),
                'href' => XenForo_Link::buildPublicLink('full:resources'),
                'position' => 'home',
                'linksTemplate' => 'resources_tab_links'
            );
https://www.axivo.com/
 

Hornstar

Well-known member
#5
I use this on our live site:
/library/XenResource/Listener/Template.php
Code:
            $extraTabs['resources'] = array(
                'title' => new XenForo_Phrase('home'),
                'href' => XenForo_Link::buildPublicLink('full:resources'),
                'position' => 'home',
                'linksTemplate' => 'resources_tab_links'
            );
https://www.axivo.com/
So just making sure I understand this correctly, will the above make the portal appear that it is in the root when everything else is in the forums directory?
 
Status
Not open for further replies.