1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 How to get animated profile gif's images to show on threads?

Discussion in 'Styling and Customization Questions' started by XxUnkn0wnxX, Oct 23, 2013.

  1. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    when i go to my profile page the animation of the gif shows but when i click on a member or go to a thread the image is still and does not animate, is there a template mod or add one that can allow this to work?
     
  2. whynot

    whynot Well-Known Member

    Is ImageMagick enabled?
     
  3. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    umm yes... not 100% sure if it installed on hostgator but they said it installed on most servers
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Create a new .php file (call it whatever you want) and in it put
    Code:
    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    
    and save it to your website location. Then browse to that file. It will tell you what all is installed for PHP.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    No need to do that, it's available from the ACP.

    admin.php?tools/phpinfo
     
    Tracy Perry likes this.
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Didn't know about that.... no option to select on the menus that I could find. Would be a good idea to add that in as a menu option? I know that myBB has a "View PHP Info" in their tools area.
    Otherwise you have to know the "secret code". :p
     
    CyclingTribe likes this.
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Just made an entry into the Suggestions forum to reflect adding the link into the Tools menu.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    It's been in my signature for several years and I have posted about it previously, so it's not exactly "secret".
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

    Point being..... digging through 8 links (luckily it's in the FAQ in the fourth post) and not being in the official help area doesn't make much sense. If anything, it should be somewhere in the official HELP option from the Home screen. I did a search on phpinfo from there and nothing was shown. Most people won't hunt for one of your posts, then look at the signature and then start searching through the links for that nor would they think to look in the resources for the FAQ as they would "assume" if it was official it would be in the documentation provided online.;)
     
  10. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    Code:
    imagick
    imagick module    enabled
    imagick module version    3.0.1
    imagick classes    Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
    ImageMagick version    ImageMagick 6.7.6-8 2012-05-02 Q16 http://www.imagemagick.org
    ImageMagick copyright    Copyright (C) 1999-2012 ImageMagick Studio LLC
    ImageMagick release date    2012-05-02
    ImageMagick number of supported formats:    200
    ImageMagick supported formats    3FR, A, AAI, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FITS, FRACTAL, FTS, G, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, J2C, JNG, JP2, JPC, JPEG, JPG, JPX, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAP, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICT, PIX, PJPEG, PLASMA, PNG, PNG24, PNG32, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RGB, RGBA, RGBO, RLA, RLE, SCR, SCT, SFW, SGI, SHTML, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XV, Y
    
    Directive    Local Value    Master Value
    imagick.locale_fix    0    0
    imagick.progress_monitor    0    0
    
    and

    Code:
    magickwand
    MagickWand Backend Library    ImageMagick
    MagickWand Extension Version    1.0.8
    ImageMagick support    enabled
    ImageMagick version    ImageMagick 6.7.6-8 2012-05-02 Q16 http://www.imagemagick.org
    ImageMagick QuantumRange (MaxRGB)    65535
    MagickWand supported image formats    3FR, A, AAI, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FITS, FRACTAL, FTS, G, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, J2C, JNG, JP2, JPC, JPEG, JPG, JPX, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAP, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICT, PIX, PJPEG, PLASMA, PNG, PNG24, PNG32, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RGB, RGBA, RGBO, RLA, RLE, SCR, SCT, SFW, SGI, SHTML, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XV, Y 
    but i get this server error when i enable and try to upload / my profile image using ImageMagick:

    Code:
    Error Info
    ErrorException: Fatal Error: Call to undefined method XenForo_Image_Imagemagick_Pecl::thumbnailFixedLongerSide() - library/Waindigo/Avatar/Extend/XenForo/Model/Avatar.php:186
    Generated By: XxUnkn0wnxX, 36 minutes ago
    Stack Trace
    
    #0 [internal function]: XenForo_Application::handleFatalError(1, '/tmp/phpTuxkHa', 2, 225, 225, Array)
    #1 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(53) "http://portalcentric.net/forums/account/avatar-upload"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(9) {
        ["use_gravatar"] => string(1) "0"
        ["scale_to_fit"] => string(1) "1"
        ["avatar_date"] => string(10) "1380121676"
        ["avatar_crop_x"] => string(1) "0"
        ["avatar_crop_y"] => string(1) "0"
        ["_xfToken"] => string(8) "********"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(9) "json-text"
        ["_xfUploader"] => string(1) "1"
      }
    }
    
     
  11. whynot

    whynot Well-Known Member

    Go to their support and tell them about your problem with it.
    imagick might happen...
     
  12. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    last time i asked something related to an error from my site they suggested to re-install the software package or told me to fix it my self because they don't do any thing to fix website errors. unless they get some kind of error report from the server.
     
  13. Mike

    Mike XenForo Developer Staff Member

    That particular error is from an add-on - something Waindigo related.
     
  14. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

  15. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ok i no longer get this error, it is all fixed up now but i still don't get animated pictures through my forum. they show fine on profile page but not when inside the forums like, take it here for example see my picture on the side here i want that to be animating on my site but still doesn't work and there are no error logs either.

    this the all i have in php related to imagick:
    [​IMG]
     
  16. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ok nm it works, just needed to do some trial and error
     

Share This Page