• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Is there any other option to get animated avatars to work ?

RAHSTYLES

Active member
#1
without the use of imageik... I asked my serverguy and they said they can only do gd2 bcause it puts more server load. I have a shared? Is there any other option? I dont get why its animated on the profile page but in the postbit its not animated.. But for vb they had animated avi in post bit without the imagik..

Now that isnt a reason to leave xenforo.. but its like a pain in the back of my neck that i wont ever be able to have a animated avatar unless i go to a dedicated server... or vps.

Such a great software and vb does one thing better.. animated gif avatars..
 

Steve F

Well-known member
#2
vB used standard sized avatars, with XenForo there are many different sized avatars so things need resized and simply resizing a gif image won't maintain the animation unless Imagick is used.

If I were in your position and animated avatars were that important I would simply move to a cheap VPS or find a shared host that will enable Imagick.
 

RAHSTYLES

Active member
#3
vB used standard sized avatars, with XenForo there are many different sized avatars so things need resized and simply resizing a gif image won't maintain the animation unless Imagick is used.

If I were in your position and animated avatars were that important I would simply move to a cheap VPS or find a shared host that will enable Imagick.
Is there any other way around it? What if there was an option to not resize the avatars.. And also if this was the case then why is it animated in profile view?
 

Mike

XenForo developer
Staff member
#4
The profile view one is not always resized. There are 2 other sizes that always need to be generated.

So no, there isn't a way around it really.
 

rwm1962

Active member
#8
I'm on a shared server but have imagemagik installed & ran a php script to check it works. I can only get avatars to show as animated in profile - not on the post bit.

Is there other tweaking required?
 

rwm1962

Active member
#12
Hi,
Thanks for the advice.

My service came back with this:

We have installed ImageMagick 6.8.9-7 under /usr/local/bin.
Please use "/usr/local/bin/convert" as the new ImageMagick binary path in order to use the 6.8.7

The original/supported version of ImageMagick 6.5.4 is still installed under /usr/bin/convert
I reckon that's also a hint that the latest version isn't supported.

Is there somewhere in the XF files I can alter the path?
 

rwm1962

Active member
#13
Reading that back I think there may be typo's in that response re the paths. I've asked for confirmation.

Question still stands though.
 

Mike

XenForo developer
Staff member
#14
Is there somewhere in the XF files I can alter the path?
No, because XF uses the imagick PHP PECL extension, which itself is directly compiled against the ImageMagick libraries on your server. To be clear, we don't use ImageMagick binaries like "convert".

The imagick extension may need to be recompiled specifically against the new ImageMagick they installed (assuming the new version isn't showing up in PHP info).
 

rwm1962

Active member
#15
Thanks Mike - no change on the phpinfo so new version not being applied for me. I'll copy your response to my service as it's beyond me.

Cheers.
 

Rob

Well-known member
#16
Nothing distracts my reading any page of content more than animation. Adverts I accept, but avatars.... urrrghgghhh.
I'm glad this is not easily possible :)
 

rwm1962

Active member
#17
It's something we have at the moment & we don't allow very big avatars & it's not really been a distraction as they are a minority & nicely done. It's no biggy for me personally but we have to move from a package that is EOL & undeveloped for around 3 years. As well as having to move I'm hoping members will see it as progress. I'm having to spend a lot of money on custom add-ons to achieve that aim. While I'm happy enough to do that & am looking to forward to being a long term XF customer I hadn't expected to loose something this basic.

@Mike
response from my service. Also above my head!

Surely the developers have offered a solution to executing "/usr/local/bin/convert" as opposed to "/usr/bin/convert".
Have you tried directly modifying your script?

The second version of ImageMagick was installed under /usr/local/bin/convert -- this was done in an effort to preserve system package consistency.
A second version was installed, your script needs to simply execute the new path.
Back later.
 

Mike

XenForo developer
Staff member
#19
I'm not sure how to respond to your host's latest message as my previous message explicitly mentioned that the ImageMagick binaries aren't used. It uses this PECL extension: http://pecl.php.net/package/imagick When this is compiled, it's compiled against the ImageMagick that's installed at the time, so it will likely need to be recompiled.

I have looked at the C code behind it and I think it will look for the library files from ImageMagick in /usr/local... before /usr... so it should pick them up when recompiling. (If it doesn't, the compilation can take a --with-imagick option to specify an overriding path.)