1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 How to edit outbound e-mails?

Discussion in 'XenForo Questions and Support' started by Carlos, Jan 29, 2012.

  1. Carlos

    Carlos Well-Known Member

    I recieved an e-mail earlier today, and I found an inspiration from this message:

    "Dear [username],

    [username] has requested that you become friends. You can approve or deny this request by visiting:

    http://forums.digitalpoint.com/profile.php?do=buddylist

    All the best,
    Digital Point Forums

    -----
    Follow us on Twitter: http://twitter.com/digitalpoint
    -----
    Advertise on digitalpoint.com (banner, inline or email): http://forums.digitalpoint.com/advertising.php"

    The question that I have: Is there a e-mail template that I can edit to put in "Follow us on Twitter." and other information?

    I feel like I haven't utilized the xenForo e-mail system as much I should have.
     
  2. Vincent

    Vincent Well-Known Member

    Enable Debug Mode --> ACP --> Development -> Email Templates

    And then you can edit MAIL_CONTAINER with the content you like. It should appear always, in every mail then :)
     
  3. Carlos

    Carlos Well-Known Member

    Can you explain how to get to debug mode? Cause I don't see it in my ACP?
     
  4. steel_curtain

    steel_curtain Well-Known Member

    Add this to your config.php file.

    Code:
    $config['debug'] = 1;
     
  5. Morgain

    Morgain Well-Known Member

    I just want to edit the View this Thread button to make it more prominent.
    Do I need to do grownup things like debug mode for that?
     
  6. Carlos

    Carlos Well-Known Member

    When I tried editing the template, I edited this way:

    This is what the test showed me:

    " It works
    On Jan 29, 2012 5:57 PM,
    "MVC3Forum" <carlos@mw3blog.com> wrote: > testing e-mail >"
     
  7. Carlos

    Carlos Well-Known Member

    I took out the "<" and it showed me no twitter.... Hmph. What am I missing here?
     
  8. Trombones13

    Trombones13 Well-Known Member

    If I'm understanding you correctly, it's that your text isn't inside the anchor tags. It should look like this:
    Code:
    <a href="http://www.twitter.com/MVC3Forum" title="Marvel Vs Capcom 3 Forum Twitter">Follow us on Twitter</a>
    (though I don't think that title attribute does anything)
    or
    Code:
    Follow us on Twitter: <a href="http://www.twitter.com/MVC3Forum">Marvel Vs Capcom 3 Forum Twitter</a>
     
  9. Carlos

    Carlos Well-Known Member

    Both seems viable solutions, thanks, Trombones! :)

    But it doesn't seem to show up in the e-mail when testing the e-mail template. I will try again when I edit it using the solutions you provided.
     

Share This Page