1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 How to check whether email sent out properly?

Discussion in 'Troubleshooting and Problems' started by snoopy5, Aug 26, 2013.

  1. snoopy5

    snoopy5 Well-Known Member

    Hi

    I just sent out to all my users an email via the ACP function. While this email was sening, I looged into the front-end with a differnt username - which logs me out simultaniously in the ACP as admin.

    Now I am afraid that not all emails were sent out because of this login/logout. How can I check whether all users got an email and if not, who did get one and who did not?
     
  2. Mike

    Mike XenForo Developer Staff Member

    Unfortunately there isn't really a great way to resolve the situation. You may be able to log back into the control panel with a separate tab and then refresh the original tab that was sending the email. Otherwise, you would need to examine server mail logs themselves (and there isn't really a great way to pick it back up).

    (That said, logging in via the front end shouldn't log you out of the admin. Though if you explicitly logged out of the front-end, that would log you out of the admin as well.)
     
  3. snoopy5

    snoopy5 Well-Known Member

    Hi

    thanks for the quick reply. But how does the system work in this procedure? Does that mean that as soon as I logout from the ACP, the email sending is automatically stopped?
     
  4. Mike

    Mike XenForo Developer Staff Member

    Yes. It's your requests that are sending it. You would have gotten to the next page of results and hit the login page instead.
     
  5. snoopy5

    snoopy5 Well-Known Member

    o.k., how many emails the software is sending out per batch?

    If I look in the ACP/Tools/admin protocol

    I can see man emails sent out. If I click on them, I get the following information:

    It seem sthat every email I see in the ACP has a different string. Something like this first line with page... array(9) { ["page"] => string(3) "303"
    This seems to go down like on teh other email 302, then 301 etc.

    If I take the amount of valid members who should get an email and divide this number by the # of strings, I get around 90 email per batch. Would that be a realisti number?

    Looking at the time stamp, it seems that email were send out starting on 7.20pm until 7.26 pm. So how many can it send out within 6-7 minutes?
     
  6. Mike

    Mike XenForo Developer Staff Member

    It sends to 30 per page. Total is the total matched from the search.
     
  7. snoopy5

    snoopy5 Well-Known Member

    how many pages can it "refresh" within 6-7 minutes? So that I can calculate it roughly...
     
  8. Mike

    Mike XenForo Developer Staff Member

    I couldn't really tell you as it depends on your server and how your mail is configured (and the speed of that server, if applicable) - the admin logs should show you.
     
  9. snoopy5

    snoopy5 Well-Known Member


    mmmhhh, I did not find that information in the admin logs. Could you please guide me to it?
     
  10. Mike

    Mike XenForo Developer Staff Member

    Well you found when it was on page 303. You could follow that path back to page 1 or 2 and look at the timestamps.
     
  11. snoopy5

    snoopy5 Well-Known Member

    o.k., so the last email send protocol was

    time stamp of this is 7.26pm

    the first email send log of today is:

    at 7.20pm

    it is a shared server. speed I do not know how to find out.
     
  12. Mike

    Mike XenForo Developer Staff Member

    That would indicate that it ran through 304 pages in 6 or so minutes...
     

Share This Page