1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 How hard would it be to upgrade from 1.2.5 to latest version?

Discussion in 'Installation, Upgrade, and Import Support' started by tcmw, Jul 12, 2015.

  1. tcmw

    tcmw Member

    I haven't performed an upgrade to my forum in quite a while so my question is how hard would it be to upgrade from what I have installed, 1.2.5, all the way up to whatever the latest version is now.
  2. Amaury

    Amaury Well-Known Member

    You can update directly to XenForo 1.4.8. As long as you're careful and follow all the steps, it shouldn't be too hard.

    The only thing to look out for would be add-on compatibility if you have a lot of add-ons installed and outdated style templates.

    Edit: Be sure to take a backup first! Also, have a look at this: How to upgrade to XenForo 1.3

    I couldn't find one for XenForo 1.4, but that should help.
    Last edited: Jul 13, 2015
  3. Brogan

    Brogan XenForo Moderator Staff Member

    XF 1.4 was mainly a regular update with no real issues, hence why there's no guide.

    The same applies to 1.5.
    Amaury likes this.
  4. imthebest

    imthebest Formerly Super120

    Do not upgrade right now. Wait a few weeks for 1.5 stable release and then upgrade.
  5. tcmw

    tcmw Member

    Will there be a big difference between 1.4.8 and 1.5?
  6. imthebest

    imthebest Formerly Super120

  7. Amaury

    Amaury Well-Known Member

    Yes. Have a look for yourself:

    1.4: Have You Seen...?
    1.5: Have You Seen...?

    However, I'd recommend updating to XenForo 1.4.8, anyway, as there have been a few security fixes since XenForo 1.2.5.
    D.O.A. likes this.
  8. HWS

    HWS Well-Known Member

    I've done such an upgrade (1.2.5 > 1.4.8) recently and it was very smooth without any problems at all. Just the customized style had to be adapted.

    The upgrade from 1.4.8 > 1.5.0 however did not work and brought the forum down. Thanks to the support from XF it was solved very quickly.

    I recommend to upgrade to 1.4.8 and wait for the final release of 1.5.0 before upgrading to it.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    The issue was you weren't using the correct upgrade URL.

    Nothing will change in the stable release as far as that is concerned.
  10. tcmw

    tcmw Member

    Thanks for the feedback guys. I hope to upgrade very soon.

Share This Page