XF 2.2 How can I stop members from getting indexes?

Solution
Yeah. Google has been ignoring everything and indexing members pages for me too. They are disabled for access in usergroup settings. They are also blocked with nofollow meta tag. AND they are also blocked in Robots.txt. Of course they cannot read the content on these pages so they get raw results.

No page information in search results - Search Console Help

Google actually says this on this support page:

You have a rule in your site's robots.txt file* that prevents Google from reading the page (which is how we generate a description in search results). However, this doesn't prevent Google from showing the page in Search results. Therefore if the page appears in Search results, it will appear without any description.
...

Chromaniac

Well-known member
Yeah. Google has been ignoring everything and indexing members pages for me too. They are disabled for access in usergroup settings. They are also blocked with nofollow meta tag. AND they are also blocked in Robots.txt. Of course they cannot read the content on these pages so they get raw results.

No page information in search results - Search Console Help

Google actually says this on this support page:

You have a rule in your site's robots.txt file* that prevents Google from reading the page (which is how we generate a description in search results). However, this doesn't prevent Google from showing the page in Search results. Therefore if the page appears in Search results, it will appear without any description.

Google further says that you should use noindex on pages rather than robots file if you want to prevent indexing.

Use "noindex" on your page. If using noindex, you must also remove the robots.txt rule that blocks the page to search engines. Sounds strange, but we need to be able to read the page in order to see your "noindex" instruction.

This post might help.

 
Last edited:
Solution
Top