• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Homepage Errors

#1
Logged in this morning to forum and everyone is getting this on the homepage;

Server Error
Mysqli prepare error: Table '*****_SFoperationsXENO.xf_user_ban' doesn't exist

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
  5. Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/Banning.php at line 74
  6. XenForo_Model_Banning->getBannedUserById() in XenForo/Model/UserProfile.php at line 134
  7. XenForo_Model_UserProfile->canViewFullUserProfile() in XenForo/Model/ProfilePost.php at line 516
  8. XenForo_Model_ProfilePost->canViewProfilePostAndContainer() in XenForo/ControllerPublic/Forum.php at line 62
  9. XenForo_ControllerPublic_Forum->actionIndex() in XenForo/FrontController.php at line 347
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  11. XenForo_FrontController->run() in /home/sfops/public_html/index.php at line 13

All the posts etc are still there - if I go into "new posts" I can view the posts and reply to them - and use private conversations etc. When not logged in the homepage looks just fine - but when log in, get that.

Nobody has touched any files at all since days ago, and everything was working perfectly when I went to bed - then get up to this.

Any ideas?

Thanks :)
 
#4
Hosting - incredibly helpfully - inform me that they never configured our backup service and that the ticket to do so got missed and is still outstanding (so sorry). They are suggesting I get someone to 'rebuild' the database table: "recreate it and step through errors while rebuilding it to resolve the issue."

Knowing absolutely nothing about database tables or restoring them or whatever, I have several questions:
  1. Before we moved server we did attempt to take a manual backup (which I have sitting in a google drive) at which point that table did exist - I don't really want to restore everything from 2+ weeks ago, especially when I am not 100% convinced how good that backup is anyway - but is there a way to use this backup to restore just that data table? (if that isn't how it works, sorry - I have no idea)
  2. Is this banned users table part of the basic software? As in - if I were to put brand new xenforo software on and imported all my posts, users, etc etc would this help me? (we were planning to do this anyway) I guess what I am asking is, would the this give me the table back?
  3. Failing all of that, how do I go about finding a developer to help me rebuild a data table?

Thank you as always for your help!