• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Home Page Not Working

#1
Hello, I am having trouble trying to get my home page working. Whenever I try to access my home page it gives me a "Forbidden" error and I was wondering if someone could help me out in any way. Thanks!
 
#10
You may want to ask your host to verify your file permissions. Something is set wrong as that is a server error.
So I asked my host but they don't seem to know much anything and thought that changing the forum url to the home url fixed the problem. So just to make sure all my files are supposed to be in the root directory of my main folder? I am not supposed to have the index.php in the main folder or something like that?
 
#12
Two threads in a row - weird coincidence.

This is what should be in the directory for a standard 1.2 installation:
View attachment 53789
Ok so I have all of those files. If I put it in my main directory then it will lead me to the forum but on the main url. If i put it in the webroot forum of my main diretory the forum will be on my main url/forum. The problem is that I don't think the homepage exists. If I want the xenforo forum to be on my url/forum don't I need something in the main directory along with files that you showed in the webroot?
 

Brogan

XenForo moderator
Staff member
#13
Can you post links as I am confused as to what the issue is.

When you are referring to the "home page", do you mean the forum index or something else?
 
#14
Can you post links as I am confused as to what the issue is.

When you are referring to the "home page", do you mean the forum index or something else?
Alright so homepage meaning the page you get when you click on home. I am completely new to this but I have seen many websites that use xenforo such as http://bukkit.org/ and they have a home page where they post all there news feed which I think you need xenporta to do. When you click forum on that website it brings you to the forum. This is what I am having trouble with. There is no homepage. Nothing. There is nothing in the main directory for there to be a homepage is what I am thinking but when I go to www.myfakeurl.com/forum (not actual site) which is where I installed xenforo on my webroot it works fine.
 

Brogan

XenForo moderator
Staff member
#15
Again, without actual links it's going to be difficult to help you.

The software does not come with a "home page" as such, just a forum index (which can be changed to any other default page).
An add-on is required if you want some sort of portal.
 
#16
Again, without actual links it's going to be difficult to help you.

The software does not come with a "home page" as such, just a forum index (which can be changed to any other default page).
An add-on is required if you want some sort of portal.
Ah ok I thought xenforo came with some sort of homepage that's what was confusing me. My website is here http://www.ageoffatality.com/forum/ but can you tell me how I can get a homepage seen here http://bukkit.org/ ?