1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

High CPU Load from ElasticSearch

Discussion in 'Enhanced Search Support' started by MattW, Jan 12, 2014.

  1. MattW

    MattW Well-Known Member

    I've been troubleshooting a high CPU load on a VPS.

    We moved over to this VPS a few months back, and it's been fine. Nothing has been changed on there.

    All of a sudden, we are getting high CPU usage from ElasticSearch (even when XF is configured not to use it???)

    I disabled it, and the load went down, re-enabled it, and it's gone high again

    upload_2014-1-12_11-40-50.png

    There have only been 5 posts on the forum so far today, with a total of 155,000 posts.

    I've upgraded from ES 0.90.7 to 0.90.9 (had errors with .10) and it still the same.

    Config has remained the same (same ES setup as my own server).

    Anyone else come across something like this before?
     
  2. Slavik

    Slavik XenForo Moderator Staff Member

    The only thing I can think of is do you have pre-warmers enabled?
     
  3. digitalpoint

    digitalpoint Well-Known Member

    Is your version of Java up to date? I just checked my setup and Elastic Search stays constant at 1-2% CPU utilization (so 0.01-0.02 load average). And that's without warmers or anything else (and actually under decent usage).
     
  4. MattW

    MattW Well-Known Member

    Yes, pre-warmers were enabled as per your setup guide.

    Java is the latest version.

    The setup and configuration is exactly the same as the one I run on my own VPS (and the same setup we had on the previous host before moving to Wiredtree)
     
  5. MattW

    MattW Well-Known Member

    Built a remote VPS only running ES, and pointed the forum at it

    Code:
    [root@elastic ~]# uptime
    08:01:35 up 10:53,  1 user,  load average: 0.00, 0.00, 0.00
    Not even being tickled, and it's a single VCPU 512MB DigitalOcean droplet!

    Something not right with how WiredTree report load / CPU when running Java on their VPS.
     
  6. MattW

    MattW Well-Known Member

    Just to follow up on this. We've moved the site to a new VPS, and re-enabled ES, and the load is around 0.1 now with it all enabled. It's configured exactly the same way as the previous VPS.
     
    Gazhyde likes this.
  7. digitalpoint

    digitalpoint Well-Known Member

    Strange...
     
  8. MattW

    MattW Well-Known Member

    Very! WiredTree basically blamed my configuration of ES, even though it's the same as the one on here (and what I've set up numerous times previously).
     
    Volion likes this.
  9. CyclingTribe

    CyclingTribe Well-Known Member

    Odd indeed, but good to know it's now sorted. Flippin' technology eh! :rolleyes: :LOL:
     

Share This Page