• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Help with php version warning

Bionic Rooster

Well-known member
#1
I get this warning while installing xf 1.3
Your server is running an outdated and unsupported version of PHP (5.2.17). If possible, you should upgrade to PHP 5.4 or 5.5.
So I goes to my cpanel and it's running
PHP 5.2 (Single php.ini)
Same as PHP 5.2, but all subdirectories will use ~/public_html/php.ini

yeah I can change to

1) PHP 5.4
All files with the extension .php will be handled by the PHP 5.4 engine.
2)PHP 5.4 (Single php.ini)
Same as PHP 5.4, but all subdirectories will use ~/public_html/php.ini
3)PHP 5.4 (FastCGI)
All files with the extension .php will be handled by PHP 5.4 FastCGI processes.
FastCGI for PHP makes all your PHP applications run through mod_fastcgi instead of mod_suphp. This eliminates the overhead of loading the PHP interpreter on every hit. Since it is always in memory ready for the next hit, the responses will be generated faster.


I don't understand any of this.
I take it everything I have installed, stores program, Joomla and current xf 1.2.4 forums are running this 5.2 (single php.ini
What happens to those if I change to another php version? Will the current programs crash?
 

LPH

Well-known member
#2
Will the current programs crash?
You definitely need to get away from using PHP 5.2.17 because it was end of life 3 years ago.

PHP End of Life
http://php.net/eol.php

Security vulnerabilities
http://www.cvedetails.com/version/106044/PHP-PHP-5.2.17.html

Before proceeding, you will want to test everything extensively before making the move. Backup everything - everything - again and again - and in multiple places. Create a test environment and run things to verify the sites operate as intended.

Option 3 with FastCGI is the fastest.
 

Liam W

Well-known member
#4
You definitely need to get away from using PHP 5.2.17 because it was end of life 3 years ago.

PHP End of Life
http://php.net/eol.php

Security vulnerabilities
http://www.cvedetails.com/version/106044/PHP-PHP-5.2.17.html

Before proceeding, you will want to test everything extensively before making the move. Backup everything - everything - again and again - and in multiple places. Create a test environment and run things to verify the sites operate as intended.

Option 3 with FastCGI is the fastest.
SuPHP would allow more secure folder permissions however, which could be a good thing...

Liam
 

Brogan

XenForo moderator
Staff member
#5
So they're finally warning people away from 5.2...
http://xenforo.com/community/resources/how-to-upgrade-to-xenforo-1-3.2810/

You may encounter some warning during the upgrade process.
These could relate to the PHP version running on your server or specific PHP functions being disabled.
While it is possible to run XenForo on PHP versions 5.2.4 - 5.3.2, it is recommended to upgrade to at least version 5.3.3 as that is the minimum version required for some libraries in use.
 

Sheratan

Well-known member
#6
SuPHP would allow more secure folder permissions however, which could be a good thing...

Liam
I believe suPHP needs more resource.

If this is your server, and all website inside that server maintained by you, I would suggest using FastCGI.
 

Bionic Rooster

Well-known member
#7
Thanks for the various bits of advise.
Version 5.3.3 was not an option, upgrades to the versions mentioned in my OP are my only choices.

I have no knowledge of PHP other than it is required to make stuff work.

What happens to those existing programs if I change to another php version? Will the current programs crash?
 

Brogan

XenForo moderator
Staff member
#8
XenForo will run on PHP 5.4/5.

I can't speak for any other software you are running on your server.
You will need to contact the relevant support departments for them.