• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help with errors on search

MattH

Active member
#1
Hi Guys,

We've been having some trouble with the server and our admin informed me he couldn't see any error logs. I'm not sure if they may just be stored somewhere else, or if there is no log, but from inside ACP I have 60+ pages from the latest Elastic Search crash.. if anyone has any insight as to what might be bringing it down that would be great!

Code:
XenForo_Exception: Elasticsearch server returned no response. Is it running? Elasticsearch indexing failed - library/XenES/Search/SourceHandler/ElasticSearch.php:850
Generated By: Unknown Account, Today at 1:53 AM
Stack Trace
#0 /home/mario/public_html/saverocity.com/public/forum/library/XenES/Search/SourceHandler/ElasticSearch.php(965): XenES_Search_SourceHandler_ElasticSearch->_logSearchResponseError(false, false, 'Elasticsearch i...')
#1 /home/mario/public_html/saverocity.com/public/forum/library/XenES/Search/SourceHandler/ElasticSearch.php(63): XenES_Search_SourceHandler_ElasticSearch->_triggerFailedIndexError(false, Array, true)
#2 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Search/Indexer.php(44): XenES_Search_SourceHandler_ElasticSearch->insertIntoIndex('thread', 271344, 'JBL Control One...', '', 1440654799, 0, 271344, Array)
#3 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Search/DataHandler/Thread.php(41): XenForo_Search_Indexer->insertIntoIndex('thread', 271344, 'JBL Control One...', '', 1440654799, 0, 271344, Array)
#4 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Search/DataHandler/Abstract.php(275): XenForo_Search_DataHandler_Thread->_insertIntoIndex(Object(XenForo_Search_Indexer), Array, NULL)
#5 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/DataWriter/Discussion.php(651): XenForo_Search_DataHandler_Abstract->insertIntoIndex(Object(XenForo_Search_Indexer), Array)
#6 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/DataWriter/Discussion.php(617): XenForo_DataWriter_Discussion->_insertIntoSearchIndex()
#7 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/DataWriter/Discussion.php(450): XenForo_DataWriter_Discussion->_indexForSearch()
#8 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/DataWriter.php(1409): XenForo_DataWriter_Discussion->_postSave()
#9 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Feed.php(499): XenForo_DataWriter->save()
#10 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Feed.php(540): XenForo_Model_Feed->_insertFeedEntry(Array, Array, Array)
#11 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Feed.php(567): XenForo_Model_Feed->_insertFeedData(Array, Array)
#12 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Feed.php(592): XenForo_Model_Feed->importFeedData(Array)
#13 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/CronEntry/Feeder.php(15): XenForo_Model_Feed->scheduledImportTimeLimited(15)
#14 [internal function]: XenForo_CronEntry_Feeder::importFeeds(Array)
#15 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Cron.php(357): call_user_func(Array, Array)
#16 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
#17 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_Cron->execute(Array, Array, 7.9999969005585, '')
#18 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999969005585, '', false)
#19 /home/mario/public_html/saverocity.com/public/forum/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#20 /home/mario/public_html/saverocity.com/public/forum/deferred.php(23): XenForo_Model_Deferred->run(false)
#21 {main}
Request State
array(3) {
["url"] => string(41) "https://saverocity.com/forum/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(66) "/forum/threads/amex-platinum.270845/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}
The other error I am seeing, not sure if it is related or might help explain the above is:

Code:
ErrorException: Fatal Error: Maximum execution time of 120 seconds exceeded -library/Zend/Feed/Reader/Entry/Rss.php:266
Generated By: Unknown Account, Today at 2:13 AM
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
["url"] => string(41) "https://saverocity.com/forum/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(39) "/forum/threads/lounge-club-hack.269682/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}
 

Brogan

XenForo moderator
Staff member
#4
Unfortunately the log entry is just telling you the service has failed.
It doesn't give any indication as to what caused it.