1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Help please

Discussion in 'XenForo Questions and Support' started by C.Stanley, Dec 1, 2013.

  1. C.Stanley

    C.Stanley Active Member

    when you go to my url myurl.com it takes you to my home page, from there you click "forums" and it takes you to my forums. But when you click my logo it takes you back to the home page. Hown can i make it when you click my logo it takes you to my forums?

    I have saw a username markup code for latest post somewhere but now cannot locate. Can someone please link me to the username markup code for latest post/thread ect.. (see attached} markup.PNG
     
  2. C.Stanley

    C.Stanley Active Member

    anyone>
     
  3. Mike

    Mike XenForo Developer Staff Member

    The logo will generally link to your "Home Page URL" option, though you can potentially change this.
     
    C.Stanley likes this.
  4. C.Stanley

    C.Stanley Active Member

    Thanks Mike, Think i found it. First i tried to change homepage url which didnt work. Then i opened template>header>logo block and code is

    Code:
    <xen:if is="{$visitor.is_moderator} || {$visitor.is_admin}">
    <div id="logoBlock">
    <div id="logo"><a href="{$logoLink}">
             <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
             <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
    </a></div>
    <xen:elseif is="{$visitor.user_id}" />
    <div id="logoBlock1">
    <div id="logo"><a href="{$logoLink}">
             <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
             <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
    </a></div>
    <xen:else />
    <div id="logoBlock">
    <div id="logo"><a href="{$logoLink}">
             <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
             <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
    </a></div>
    </xen:if>
       <div class="pageWidth">
         <div class="pageContent">
           <xen:include template="ad_header" />
           <xen:hook name="header_logo">
           
           </xen:hook>
           <span class="helper"></span>
         </div>
       </div>
    </div>
    
    so if i
    Find: <div id="logo"><a href="{$logoLink}">
    change the a href to forum url it should work?
     
  5. Mike

    Mike XenForo Developer Staff Member

    Yes, that should be fine.
     
    C.Stanley likes this.
  6. C.Stanley

    C.Stanley Active Member

    Thanks got it. I changed in all three places. Correct?
     
  7. Jeremy

    Jeremy XenForo Moderator Staff Member

    Yes.
     

Share This Page